Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was downloading a 4.0 GB file using axel. When it reached 98%, it displayed "Write Error". I still have 30+ GB of free disk space.

I tried to run axel again, and got "Write Error" again. Here is the actual display:

State file found: 4251724925 bytes downloaded, 62428035 to go.
Starting download

,,,,,,,,,, ,,,,,,,,,, ,,,,,.....

Write error!

Downloaded 5.0 kilobytes in 0 seconds. (0.00 KB/s)

How can I fix this?

share|improve this question
Is axel axel.alioth.debian.org? Is this over http? Have you tried with a different download client, say wget? wget -c has the advantage of being restartable. – Faheem Mitha May 25 '11 at 15:59
I'm using Gentoo. Ang I installed axel using the emerge feature of Gentoo so I have no idea where axel came from. Anyway, I am certain that it is over http. I will try wget if this issue cannot be fixed. Thanks. – Neigyl Noval May 25 '11 at 16:03
Does axel support restartable downloads? Also, your package manager may show the home page. With Debian, apt-cache show axel shows the page. In any case, I expect it is the same project. Yes, I'd give wget a try if applicable. – Faheem Mitha May 25 '11 at 16:04
On experience, download continues when I restart axel from which it ended from. – Neigyl Noval May 25 '11 at 16:06
You could give the axel mailing lists a try. If the file is publicly downloadable. I recommend you submit a bug report. – Faheem Mitha May 25 '11 at 16:08
up vote 5 down vote accepted

Which version are you using? You might have been hit by this bug if the version you've installed is too old to include its patch.

share|improve this answer
I was using 2.3. I have just downloaded 2.4 and it worked very fine. Thanks! – Neigyl Noval May 25 '11 at 16:35

FAT32 has a 4Gbyte limit for files. If you're saving this to a FAT32 partition or flash drive this could be an issue.

share|improve this answer
The partition saved is actually ext3. Will that bear same issue? How to solve it? – Neigyl Noval May 25 '11 at 15:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.