Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently tried to install a package in Mint 16 and the next thing I knew it uninstalled cinnamon and mint. Now, when I boot I am taken to a Ubuntu startup page. (Which fails to load because of an error "stopping startpar bridge for notification of upstart job start/stop") and it just freezes there. I then got the live cd out and booted from there and mounted my old drive (eg chroot). All my files are there but when I try to "sudo apt-get update" I get:

"Could not resolve security.ubuntu.com" and "Could not resolve archive.ubuntu.com".

How do I restore Mint?

EDIT: I was trying to install AceStream and then it told me that the following packages are not necessary and it gave me a big list of packages and I hit "Enter" not even thinking.

Now, when I boot I get Ubuntu 13.10 and an error message kvm: disabled by bios. If I press Esc, I see an error message on the command line stopping startpar bridge for notification of upstart job start/stop. Thus, Ubuntu is loading, not Mint (even though Mint is the only OS I have on this machine).

I then have to use the Live CD to then chroot into my files.

EDIT#2: I was able to cp /etc/resolv.conf /mnt/etc/resolv.conf once I was chrooted and that solved the networking issues. I was then able to apt-get update and then apt-get dist-upgrade. I then tried to boot without the Live CD but I'm still being thrown to the Ubuntu splash screen with the same error kvm: disabled by bios

share|improve this question

closed as off-topic by Braiam, slm, maxschlepzig, jasonwryan, Ramesh Jun 15 at 23:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Braiam, slm, maxschlepzig, jasonwryan, Ramesh
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you ping those domains? ping -c2 security.ubuntu.com? –  Braiam Jun 15 at 19:06
    
Please edit your question and i) show us the contents of your /etc/apt/sources.list ii) tell us which package you upgraded iii) explain what exactly you mean by "uninstalled mint", Mint is your OS, how exactly was it uninstalled? –  terdon Jun 15 at 19:08
    
@terdon: please see my edits. –  Mr. Gaga Jun 15 at 19:56
    
@Braiam: I was able to solve the networking issues. Please see my edits. Thanks! –  Mr. Gaga Jun 15 at 19:57
    
I would love to answer & close this question but it's on hold..... –  Mr. Gaga Jun 16 at 17:03

Browse other questions tagged or ask your own question.