Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Running Ubuntu 14.04 on a custom build. I have Encore wireless N300 PCI-E Adapter ( seen here ) The driver is available for download at this link as well. I am reading that a common fix for connection issues is to uninstall/reinstall the wireless driver. But before I jump the gun, I wonder if there is some other things I should look at first? Also, once downloaded, how do I install?

It only drops connection for a second, and then re connects. The problem is, I lose my VPN connection and it then reconnects clean. (WiFi drops regardless of vpn or open)

Note: I also have this posted for a few days in Ubuntuforums, but I've gotten no response yet.

lspci

Network controller: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter (rev 01)

lsmod | grep rtl:

rtl8192ce              53550  0
rtl_pci                26690  1 rtl8192ce
rtlwifi                63475  2 rtl_pci,rtl8192ce
rtl8192c_common        53172  1 rtl8192ce
mac80211              626557  3 rtl_pci,rtlwifi,rtl8192ce
cfg80211              484040  2 mac80211,rtlwifi

iwconfig | grep Power
eth0      no wireless extensions.

lo        no wireless extensions.

          Bit Rate=144.4 Mb/s   Tx-Power=20 dBm  
          Power Management:off

wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script:

########## wireless info START ##########

##### release #####

Distributor ID:    Ubuntu
Description:    Ubuntu 14.04 LTS
Release:    14.04
Codename:    trusty

##### kernel #####

Linux mike-System-Product-Name 3.13.0-29-generic #53-Ubuntu SMP Wed Jun 4 21:00:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

##### lspci #####

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 09)
    Subsystem: ASUSTeK Computer Inc. P8H77-I Motherboard [1043:8505]
    Kernel driver in use: r8169

06:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter [10ec:8178] (rev 01)
    Subsystem: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter [10ec:8178]
    Kernel driver in use: rtl8192ce
07:00.0 USB controller [0c03]: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller [1b21:1042]

##### lsusb #####

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04d9:a06b Holtek Semiconductor, Inc.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 03f0:8904 Hewlett-Packard DeskJet 6940 series
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA Card Info #####

##### rfkill #####

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

##### iw reg get #####

country 00:
    (2402 - 2472 @ 40), (3, 20)
    (2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
    (5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

##### interfaces #####

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

##### iwconfig #####

wlan0     IEEE 802.11bgn  ESSID:"HighMoon"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: <MAC address removed>  
          Bit Rate=144.4 Mb/s   Tx-Power=20 dBm  
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=20 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:88   Missed beacon:0

##### route #####

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

##### resolv.conf #####

nameserver 127.0.1.1
search hsd1.pa.comcast.net

##### nm-tool #####

NetworkManager Tool

State: connected (global)

- Device: wlan0  [HighMoon] ----------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8192ce
  State:             connected
  Default:           yes
  HW Address:        <MAC address removed>

  Capabilities:
    Speed:           144 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    HighMoon-guest:  Infra, <MAC address removed>, Freq 2437 MHz, Rate 54 Mb/s, Strength 97
    *HighMoon:       Infra, <MAC address removed>, Freq 2437 MHz, Rate 54 Mb/s, Strength 100 WPA2

  IPv4 Settings:
    Address:         192.168.1.146
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             75.75.76.76
    DNS:             75.75.75.75
    DNS:             192.168.1.1

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        <MAC address removed>

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

##### NetworkManager.state #####

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf #####

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### iwlist #####

wlan0     Scan completed :
          Cell 01 - Address: <MAC address removed>
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70  Signal level=26 dBm  
                    Encryption key:on
                    ESSID:"HighMoon"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000000000000000
                    Extra: Last beacon: 0ms ago
                    IE: Unknown: 0008486967684D6F6F6E
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1606081500000000000000000000000000000000000000
                    IE: Unknown: DD810050F204104A00011010440001021041000100103B0001031047001002519461683B1AF5B2843176671BB6DB102100074C696E6B7379731023000D4C696E6B7379732045343230301024000776312E302E30321042000234321054000800060050F20400011011000D4C696E6B737973204534323030100800020084103C000103
                    IE: Unknown: DD090010180203F02C0000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
          Cell 02 - Address: <MAC address removed>
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70  Signal level=26 dBm  
                    Encryption key:off
                    ESSID:"HighMoon-guest"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000000000000000
                    Extra: Last beacon: 0ms ago
                    IE: Unknown: 000E486967684D6F6F6E2D6775657374
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1606081100000000000000000000000000000000000000
                    IE: Unknown: DD090010180200F02C0000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

##### iwlist channel #####

wlan0     13 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Current Frequency:2.437 GHz (Channel 6)

##### lsmod #####

rtl8192ce              53550  0
rtl_pci                26690  1 rtl8192ce
rtlwifi                63475  2 rtl_pci,rtl8192ce
rtl8192c_common        53172  1 rtl8192ce
mac80211              626557  3 rtl_pci,rtlwifi,rtl8192ce
cfg80211              484040  2 mac80211,rtlwifi

##### modinfo #####

filename:       /lib/modules/3.13.0-29-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
firmware:       rtlwifi/rtl8192cfwU_B.bin
firmware:       rtlwifi/rtl8192cfwU.bin
firmware:       rtlwifi/rtl8192cfw.bin
description:    Realtek 8192C/8188C 802.11n PCI wireless
license:        GPL
author:         Larry Finger    <Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE    <wlanfae@realtek.com>
author:         lizhaoming    <chaoming_li@realsil.com.cn>
srcversion:     EF063698748457BBEDB4633
alias:          pci:v000010ECd00008176sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008177sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008178sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008191sv*sd*bc*sc*i*
depends:        rtlwifi,rtl_pci,rtl8192c-common,mac80211
intree:         Y
vermagic:       3.13.0-29-generic SMP mod_unload modversions
signer:         Magrathea: Glacier signing key
sig_key:        <MAC address removed>:3B:EA:01:C4:BD:A9:65:67:CF:A7:23:C9:70:D8
sig_hashalgo:   sha512
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)

filename:       /lib/modules/3.13.0-29-generic/kernel/drivers/net/wireless/rtlwifi/rtl_pci.ko
description:    PCI basic driver for rtlwifi
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE    <wlanfae@realtek.com>
author:         lizhaoming    <chaoming_li@realsil.com.cn>
srcversion:     9B7F19319428FF0EFE7E350
depends:        mac80211,rtlwifi
intree:         Y
vermagic:       3.13.0-29-generic SMP mod_unload modversions
signer:         Magrathea: Glacier signing key
sig_key:        <MAC address removed>:3B:EA:01:C4:BD:A9:65:67:CF:A7:23:C9:70:D8
sig_hashalgo:   sha512

filename:       /lib/modules/3.13.0-29-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
description:    Realtek 802.11n PCI wireless core
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE    <wlanfae@realtek.com>
author:         lizhaoming    <chaoming_li@realsil.com.cn>
srcversion:     27E91755814596D634B7709
depends:        mac80211,cfg80211
intree:         Y
vermagic:       3.13.0-29-generic SMP mod_unload modversions
signer:         Magrathea: Glacier signing key
sig_key:        <MAC address removed>:3B:EA:01:C4:BD:A9:65:67:CF:A7:23:C9:70:D8
sig_hashalgo:   sha512

filename:       /lib/modules/3.13.0-29-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192c/rtl8192c-common.ko
description:    Realtek 8192C/8188C 802.11n PCI wireless
license:        GPL
author:         Larry Finger    <Larry.Finger@lwfinger.net>
author:         Ziv Huang    <ziv_huang@realtek.com>
author:         Georgia        <georgia@realtek.com>
author:         Realtek WlanFAE    <wlanfae@realtek.com>
author:         lizhaoming    <chaoming_li@realsil.com.cn>
srcversion:     32F826C623BC49F764F7974
depends:        
intree:         Y
vermagic:       3.13.0-29-generic SMP mod_unload modversions
signer:         Magrathea: Glacier signing key
sig_key:        <MAC address removed>:3B:EA:01:C4:BD:A9:65:67:CF:A7:23:C9:70:D8
sig_hashalgo:   sha512

##### modules #####

lp
rtc

coretemp
nct6775

coretemp
nct6775

##### blacklist #####

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/fbdev-blacklist.conf]
blacklist arkfb
blacklist aty128fb
blacklist atyfb
blacklist radeonfb
blacklist cirrusfb
blacklist cyber2000fb
blacklist gx1fb
blacklist gxfb
blacklist kyrofb
blacklist matroxfb_base
blacklist mb862xxfb
blacklist neofb
blacklist nvidiafb
blacklist pm2fb
blacklist pm3fb
blacklist s3fb
blacklist savagefb
blacklist sisfb
blacklist tdfxfb
blacklist tridentfb
blacklist viafb
blacklist vt8623fb

##### udev rules #####

# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address removed>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10ec:0x8178 (rtl8192ce)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address removed>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

##### dmesg #####

[    5.120047] rtl8192ce: Using firmware rtlwifi/rtl8192cfw.bin
[    5.194147] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[    5.194286] rtlwifi: wireless switch is on
[    8.897871] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    8.898113] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   11.059263] wlan0: authenticate with <MAC address removed>
[   11.079193] wlan0: send auth to <MAC address removed> (try 1/3)
[   11.080713] wlan0: authenticated
[   11.082910] wlan0: associate with <MAC address removed> (try 1/3)
[   11.085949] wlan0: RX AssocResp from <MAC address removed> (capab=0x411 status=0 aid=2)
[   11.086080] wlan0: associated
[   11.086087] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   11.130630] wlan0: deauthenticating from <MAC address removed> by local choice (reason=2)
[   11.161112] wlan0: authenticate with <MAC address removed>
[   11.507939] wlan0: send auth to <MAC address removed> (try 1/3)
[   11.509417] wlan0: authenticated
[   11.510494] wlan0: associate with <MAC address removed> (try 1/3)
[   11.517862] wlan0: RX AssocResp from <MAC address removed> (capab=0x411 status=0 aid=2)
[   11.517993] wlan0: associated
[   19.514761] wlan0: Connection to AP <MAC address removed> lost
[   20.825705] wlan0: authenticate with <MAC address removed>
[   20.845680] wlan0: send auth to <MAC address removed> (try 1/3)
[   20.849279] wlan0: authenticated
[   20.853472] wlan0: associate with <MAC address removed> (try 1/3)
[   20.856489] wlan0: RX AssocResp from <MAC address removed> (capab=0x411 status=0 aid=2)
[   20.856620] wlan0: associated

########## wireless info END ############

Also went into Network Manager and locked in BSSID number in previously blank field. Still, I see the WiFi icon fluctuating. BSSID found through running:

cat /var/log/syslog | grep -e etwork -e wlan | tail -n20

Which gave me a message:

WLAN:0 WPA: GROUP
Rekeying completed with ( BSSID NUMBER)
[GTK=CCMP]
share|improve this question
    
I've had this problem since I bought my wifi card with the same chipset. I'm pretty sure it's the chipset itself. I've googled for about 2 years and never found anything that works 100%. –  Chris Jul 21 at 17:04
    
If you'd like to figure out how to at least get your VPN to not drop & reconnect, I suggest asking that as a separate question. I bet that's easier to solve... –  derobert Aug 15 at 2:21

1 Answer 1

Im am very sorry about my previous answer, even though it is written in large font that you are using 14.04; it didnt occur to me that you were, I thought you were using 12.04.

I personally am typing this using 14.04 Gnome Buntu. The driver for this edition actually comes out of the box on the distro and works decently well but there is some funky issues I'm tracking, that aren't making sense. The build file is no longer where it was and there is funky c/c++ arch cross compile pointer issue.

On Gnome Ubuntu 14.04, do not blacklist the driver.

Regardless I hope this will help you diagnosticly, assuming the problem is on your end of the vpn, so please read the following.

I have to ask you some trouble shooting questions that you need to ask/answer yourself and your system. They are as follows:

  1. Do you have a root password set? You can check by entering the /etc/shadow file:

    :~$ sudo nano /etc/shadow
    

    If the first line of the file isnt quite long from the encryption you need to set one, or better yet back up your data to a USB and perform a complete re-install: if you choose to re-install, delete all virtual machines before doing so (you should probably want to create a script that purges and removes all the major applications on the system), might even want to DBAN your system (takes 8 to 24 hours).

    I say completely reinstall, if you didn't have a root password set, because you now have no idea what hidden scripts have been placed on your system (unless you've been using tripwire) you know? A script could be "phoning home" during your vpn and this could be causing the kernel to kick the connection.

  2. What distro are you using, Ubuntu 14.04 or a variant built on top of 14.04 (e.g Gnome Ubuntu), and what display manager, or combination of display managers is your system using?

    There have been some changes made in the start up to log in of the xgreeter session between 12.04 and 14.04, it might take a little while (100 or more seconds post log in) for the greeter session to kill its pts, if you are immediately jumping on the system and initiating a VPN, this could cause the kernel to kick the connection.

  3. When you first log in to your user account after doing a reboot, run the who command from command line, open a terminal Ctrl+T

    :~$ who
    

    what is the output displayed, are you using the pts/0 of the ptmx master-slave relationship. Obviously you are tty7, what is your pts? you should be zero.

  4. Assuming you are not pts/0, what is your pts: pts/9, pts/12, pts/15? What upstart jobs is your system running at system start?

    Power down you system. Let the electricity leave your RAM and restart it. Immediately open a terminal instance Ctrl+T as soon as you log in and Run the following commands:

    :~$ ps -a > psOfA.txt
    :~$ sudo status modemmanager
    :~$ sudo status cups
    :~$ sudo status cups-browsed
    :~$ sudo status bluetooth
    

    If you are ssh tunneling over a VPN from a desktop that is not hard-wired ("Ether cable cat3 or cat5") to a router, I guarantee you that you do not want these active!

    You need to kill these job processes. Go into the /etc/init directory and comment-out (with #) in front of the start and exec lines of the .conf file of the four previously stated jobs. The start line of the file may take up two lines, comment out both of them.

    Check the text file you created with the ps -a command and pay attention to what the job process sequence is, at system start up, anything look out of place to you? You should have like kinit, getty, system.d, etc. But is there any application running in the back ground that you never use at start up?

  5. Do you have Rkhunter, unhide, and gkrellm installed? If not, install them! Do you know what make and model processor you are using, and if that processor allows sensor reading technology? If you are using an intel cpu, you can check its information here.

    If your cpu has sensor reading technology (and it should if you are using an Intel), initiate and configure the Gkrellm application to show the, temperature, wlan and the lo even when not connected to the internet!

    With your adapter not plugged in and your internet turned off what is the lo reading? Is it jacked up like 480 constant? If its at zero your ok.

    Also run the following commands with the internet turned on and adapter in:

    :~$ sudo unhide-tcp help
    :~$ sudo unhide checkbrute
    :~$ sudo rkhunter --propupd
    :~$ sudo rkhunter --checkall
    

    After running rkhunter do you have any warnings? If its the first time you have ran rkhunter, you should have warnings for password and group file changes. Learn how to configure rkhunter, if you haven't already done so!

    You can check the messages in the /var/log/rkhunter file. Open it using gedit from the command line with sudo, and copy and paste it to a new file your own.

  6. If you are VPN ing you probably want open-ssh server installed, it doesn't come installed by default. Use the sudo updatedb command followed by locate ssh from command line to get a handle on where the ssh files are located with in your system. The config files should be in the /etc/ssh directory.

  7. After running the ifconfig -a and the iwconfig commands as shown below what is the output:

    :~$ ifconfig -a
    :~$ iwconfig 
    

    (This is very important and probably should have been further up the list, but other things have come to mind so asked/directed them first)

    What is the RTS throw and RTX readings of the iwconfig command? Is the rts set set to off? If the rts reading is not off you have 'noise', if you are using those rtl8192 drivers.

    The rts object is not persistent across boots, and some model adapters will not let you set it; but give it a shot with the following command once your systems start up jobs have died down and you are using the pts/0 master slave relationship:

    :~$ sudo iwconfig wlan0 rts off
    

    After running the preceding command run sudo updatedb and close the terminal reopen the another terminal and run the iwconfig command again, is your rts now set to off? If it is your model adatper allows you to set rts, create a script to run every time you log in, as shown below:

#! /bin/bash
IWCONFIG_OPT="sudo iwconfig wlan0 rts off"
$IWCONFIG_OPT;

exit;

Name the script what you want, but you must run it after you have been granted temp root/superuser permissions by your terminal instance so either log into bash (e.g. sudo bash) and then exit root instance of bash by typing exit and run the script or use sudo updatedb. Those are the two easiest so thats why I mentioned them.

You can name the script yourname.sh and run it as ./yourname.sh or you can leave off a file type (e.g. justyourfilename) and run it from the directory it is located in with a dollar bill sign in front of the name of the script as shown below: (its still a shell/x-application)

:~$ sudo chmod +x yourname.sh
:~$ sudo chmod +x yourname
:~$ sudo bash 
:~# exit
:~$ $yourname

This will keep the 'noise' down, in the gkrellm instruction that was mentioned in step 6 was your lo zero or was it reading something like 480 across the board? It should not be reading 480 thats giving interference to your actual at that run level. This is more than likely coming from some package/module installed from a video/sound or gtk+ engine module that you have installed, that doesn't have what was being previously used as a dependency that is no longer being distributed in the base package. (Without another 20,000 words of typing thats all im gonna say about that 480 lo).

  1. If you are using Ubuntu 14.04 straight up, no variant (e.g. Gnome buntu, Zorin, xUbunu etc..) Have you killed the guest account at login? Meaning your hiding the guest account at login. If you haven't you should. You can do this by adding the following to the file shown below:

    :~$ sudo nano /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

    allow-guest=false

Do not restart lightdm after making the changes just reboot it command e.g. sudo reboot.

Keep running rkhunter, lock your system down, and configure ssh; afterwards let us know what your seeing. Also what are you using the vpn for? Connecting to a DB of some type or development platform? What type of system and whats the security of the system?

share|improve this answer
2  
Welcome to Unix & Linux. Please try to keep your answers short and to the point. This one is far too rambling. If you have questions for the OP, ask them as comments rather than in your answer (though you must gain sufficient reputation first). –  drs Aug 25 at 1:05
    
I am sorry about that. There is alot of variables in the equation that could be causing that fellows problems. Because of that I felt the questions needed to be asked. –  geoffW Aug 25 at 1:43
    
Also when I stated that about the scripts, the mode of access should be changed to executable (e.g. chmod +x), and in the example where A dollar sign was used you must give that files location as an environment variable with in your shell start up script, e.g. .bashrc. –  geoffW Aug 25 at 1:45
    
The link quality should also be less than one in the ratio. 70/70 is not gonna work, most adapters will not let you change but by changing the rts to off the link quality will change. In the first answer changing the limits will apply, to you since you are using a VPN those instructions should be followed regardless of distro types. –  geoffW Aug 25 at 1:48
1  
Please stop typing now... –  jasonwryan Aug 25 at 2:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.