Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've been banging my head on the keyboard with this! I'm working on CentOS 6.5 x86_64.

Firstly I tried to update php and apache using easy apache. The update failed very quickly so I went on the usual hunt around the internet. It appears I also can't run yum update. Here is the bottom of the readout:

Error: Package: glibc-utils-2.12-1.132.el6_5.2.x86_64 (updates)
       Requires: libgd.so.2()(64bit)
       Removing: gd-2.0.35-11.el6.x86_64 (@base)
           libgd.so.2()(64bit)
       Updated By: gd-2.1.0-1.el6.x86_64 (CentALT)
           Not found
Error: Package: cpanel-webalizer-2.23_05-2.cp1136.x86_64 (installed)
       Requires: libgd.so.2()(64bit)
       Removing: gd-2.0.35-11.el6.x86_64 (@base)
           libgd.so.2()(64bit)
       Updated By: gd-2.1.0-1.el6.x86_64 (CentALT)
           Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I've tried running rpm -Va --nofiles --nodigest but to no avail.

A lot of what I have read mentions repos. I have the following repos installed:

CentOS-Base.repo
CentOS-Vault.repo
mod-pagespeed.repo
CentOS-Debuginfo.repo
epel.repo
remi.repo
centalt.repo
CentOS-Media.repo
epel-testing.repo

I know there is a problem with centalt.repo as when I try to go to the base URL I get a 403:forbidden message.

I've tried using wget to install gd-2.0.35-11.el6.x86_64.rpm but it says it's already installed. Which, to me, means libgd.so.2()(64bit) should also be installed (according to http://www.rpmfind.net//linux/RPM/centos/6.5/x86_64/Packages/gd-2.0.35-11.el6.x86_64.html).

I'm really stuck here... I really hope someone can help me get this sorted out. I need to update PHP for a client.

share|improve this question
    
so you're running cpanel? –  schaiba Jun 13 at 15:44
    
First troubleshooting step should be to investigate how the CentALT repo is broken. Maybe they changed the path and this box didn't get the update? I would check their website and then manually dig into the repo settings. It obviously worked at one time... –  0xSheepdog Jun 13 at 16:01
    
Try running yum clean all && yum upgrade –  bodhi.zazen Jun 13 at 16:56

1 Answer 1

up vote 1 down vote accepted

I would simply repoint the .repo file for CentALT to one of the mirrors. The main repository indeed seems to be down, I'm only able to browse their top level URL, all the YUM URLs are returning a 403 Forbidden.

Here's one such mirror:

You can change the /etc/yum.repo.d/centos.alt.ru.repo file like so:

[CentALT]
name=CentALT Packages for Enterprise Linux 6 - $basearch
baseurl=http://mirror.neu.edu.cn/CentALT/6/$basearch/
enabled=1
gpgcheck=0

References

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.