Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Centos 5.7 operating system box and I have installed OpenSSL 1.0.1h successfully. but when I am upgrading OpenSSH I am getting the below error message while running ./configure. Kindly help me on this and let me know if you have any questions.

checking whether snprintf correctly terminates long strings... yes
checking whether snprintf can declare const char *fmt... yes
checking whether system supports SO_PEERCRED getsockopt... yes
checking for (overly) strict mkstemp... yes
checking if openpty correctly handles controlling tty... yes
checking whether getpgrp requires zero arguments... yes
checking OpenSSL header version... 1000108f (OpenSSL 1.0.1h 5 Jun 2014)
checking OpenSSL library version... 90802f (OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008)
checking whether OpenSSL's headers match the library... no
configure: error: Your OpenSSL headers do not match your
library. Check config.log for details.
If you are sure your installation is consistent, you can disable the check
by running "./configure --without-openssl-header-check".
Also see contrib/findssl.sh for help identifying header/library mismatches.
share|improve this question
What happens if you follow the actions the configure script suggests? – mtak Jun 13 '14 at 13:07

... i have installed OpenSSL 1.0.1h ...

Yes, but only the header version. Your library is still 0.9.8e-fips-rhel5 and not 1.0.1h like your header. You need to install the matching library for your header.
Looks Like you installed OpenSSL 1.0.1h manually while 0.9.8e-fips-rhel5 seems to be a rhel version. The rhel-version probably was installed via package-management. Maybe you just need to uninstall the 0.9.8e via yum remove openssl-libs. Afterwards check if your OpenSSL 1.0.1h libraries are detected (i assume you installed header + lib). If not, install OpenSSL 1.0.1h-libs (again).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.