Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Since I use vnc through an ssh tunnel, is there any way I can block the open vnc port that the remote machine is listening on without it affecting my ability to use the ssh tunnel? Both machines are linux debian based.

share|improve this question

migrated from stackoverflow.com May 23 '11 at 18:17

This question came from our site for professional and enthusiast programmers.

2 Answers 2

I use vncserver -localhost [other options here] when I start the vncserver on my debian boxes. This means VNC only accepts connections from the loopback of the remote machine.

share|improve this answer
    
Thanks, this is the exact thing I needed. –  Christopher Dorian May 23 '11 at 4:54
    
@Christopher, you're most welcome. –  Mike Pennington May 23 '11 at 4:56

Configure the VNC server to only accept connections from your IP.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.