Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to build Scribes in Slackware64 13.37 with XFCE and I am having a lot of troubles with the Python Binding for GTK Spell. I have gtkspell-2.0.16-x86_64-1 and pygtkspell-2.25.3-i486-3sl installed but, the autogen script does not seem to find it:

...
checking for python script directory... ${prefix}/lib64/python2.6/site-packages
checking for python extension module directory... ${exec_prefix}/lib64/python2.6/site-packages
Checking for D-Bus (Python Bindings)... yes
Checking for PyGTK... yes
Checking for pygtksourceview2... yes
Error: Python bindings for gtkspell was not found.
configure: error: Error: Dependency check failed

I tried to put a link in the path mentioned there (${prefix}/lib64/python2.6/site-packages, even though I do not know where that ${prefix} points =S, so I assumed the lib64 is the one in /) because the modules for python2.6/site-packages are really located in

/usr/lib/python2.6/site-packages/gtk-2.0/gtkspell.la
/usr/lib/python2.6/site-packages/gtk-2.0/gtkspell.so

also, I tried pointing all the link all the way to /usr/lib/python2.6/site-packages/gtk-2.0/

site-packages -> /usr/lib/python2.6/site-packages/gtk-2.0/

but no luck =(.

Is there a way to specify the path to pygtkspell? should I put those modules somewhere else?

I am out of ideas, so thank you very much for yours =)

Regards,

share|improve this question
add comment

1 Answer

You're trying to use 32-bit python bindings (pygtkspell i486) with a 64-bit (x86_64) python. You can run ix86 and x86_64 binaries on the same system, but you can't load ix86 and x86_64 libraries in the same executable. Linking the wrong binaries in the right place won't help: they're still the wrong binaries. You need to obtain 64-bit bindings (pygtkspell-*-x86_64-*), or if they're not available (but they probably are), run a 32-bit python.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.