Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am having difficulty using Kubuntu (or GNOME) for work because text readability is quite poor (read headache inducing) compared to Windows Vista/7 and OS X. Any tips on how to improve font rendering or, more generally, readability would be greatly appreciated! (The NVIDIA provided driver for the FX 770M gpu is installed. Also, unlikely to be a hardware issue as the machine is dual boot with Vista, which looks fine.)

share|improve this question
add comment

3 Answers 3

This extremely subjective stuff.

But as for the facts. The code hinting patent should have just expired recently, therefore regular packages should now contain proper font hinting. Now the problem is that not all fonts support font hinting (I have no idea whether this is the case of the Ubuntu system font). Try Dejavu fonts, they do support font hinting for some time.

As for non-system fonts, try also tweaking the settings in KDE/Gnome. Both will allow you to select the style of font hinting (and font aliasing).

This link shows some old for OpenSuSe, but it contains screenshots for both KDE and Gnome, and the settings haven't really changed: http://opensuse-community.org/SubpixelHinting

share|improve this answer
    
Thanks for your answer. –  Peter May 22 '11 at 18:17
add comment

As already mentioned, this is very subjective, and there are two schools of thought:

  • Microsoft ClearType: Heavy use of hinting with focus on readability at the expense of compromising on accuracy of glyphs.
  • Mac OS X: Hints are essentially disregarded, and glyphs are represented exactly, even if this is going to cause some blurriness.

Linux gives you a choice, you can either enable full hinting to get the crisp look, or focus on font accuracy and disable hinting altogether. This can be configured either through the GNOME Appearance settings or by directly editing the fonts.conf configuration file.

share|improve this answer
add comment

Perhaps you are experiencing this.

share|improve this answer
1  
Please provide context for links. –  Gilles May 22 '11 at 15:44
    
Very helpful! Thanks. –  Peter May 22 '11 at 22:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.