Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
$ knife cookbook download recipe
zsh: correct 'cookbook' to 'cookbooks' [nyae]?

How can I get zsh to stop trying to correct cookbook to cookbooks??

cookbooks is a directory where I run the command so I understand why it's doing it, but cookbook is a valid part of the command line.

share|improve this question

migrated from stackoverflow.com May 21 '11 at 22:10

This question came from our site for professional and enthusiast programmers.

If you don't want to disable corrections completely, you should define an alias:

alias knife='nocorrect knife'
share|improve this answer

You can add setopt nocorrectall; setopt correct to your ~/.zshrc file to disable this behavior. It will still function for commands, but not for arguments.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.