Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After reformatting a disk that I think had nothing to do with the Fedora installation, it now boots always in emergency mode, no matter what "Fedora" option I choose in the bootloader

My disk configuration: I have 3 500GB disk in an array with Intel Matrix Storage. The array was split in 2 disks. One of them, Raid 0. Fedora (home, root, swap) are partitions of this disk (they aren't the only ones). The other disk in the array used to be Raid 5. I changed it to Raid 0 and formatted it to NTFS from Windows. After that, I can't boot Fedora. Windows is on a separate 1TB disk.

In the journal log, I see "red stuff" including:

  • tsc: fast tsc calibration failed
  • Failed to find module 'vboxdrv'/'vboxnetflt'/'vboxnetadp'
  • Failed to start Load Kernel Modules
  • inotify_add_watch(7, /dev/sda2, 10) failed: No such file or directory
  • inotify_add_watch(7, /dev/sda4, 10) failed: No such file or directory
  • inotify_add_watch(7, /dev/sda3, 10) failed: No such file or directory
  • inotify_add_watch(7, /dev/sda1, 10) failed: No such file or directory
  • [sdi] No Caching mode page found. Assuming drive cache: write through
  • Dependency failed for Mark the need to relabel after reboot

Clearly I have no idea which of these errors where already there when the PC worked normally. The /etc/modules.load.d folder is empty (not sure if it should be)

Thanks for the help

share|improve this question
    
Wait, RAID 0 is normally a way to combine multiple disks together where performance is all that counts; data is not redundant in any way. –  derobert Jun 6 at 22:21
    
@derobert right –  Rojo Jun 6 at 22:21
    
Up to know, all I did was fiddle around with fsck. Also yumremoved Virtual Box but the vboxdrv/etc errors didn't stop (why is VB so important that I haven't even logged in and it already tried to load its modules? I never even used it yet) –  Rojo Jun 6 at 22:31

1 Answer 1

All solved. In the /etc/fstab file, it was trying to mount a partition that isn't there any more. It seems it considered this bad enough to enter emergency mode!

share|improve this answer
    
Any tips for someone who only has /dev/mapper/fedora-root / and /dev/mapper/fedora-swap swap? I can't seem to figure out how to make it boot solidly. –  Seiyria Aug 3 at 15:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.