Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently have been trying out Arch Linux. It seems that their autofs has a usability bug, although I confess that I'm new enough to Arch that I may be missing something horribly obvious.

I want autofs to automagically mount hosts under /net like it has always done. Traditionally it used /etc/auto.net to accomplish this, however it seems that they've done away with this and now you simply use the following line:

/net -hosts --timeout=60

Fine and dandy, most things seem to work. However, under Arch it seems that ghosting is enabled by default. This is a bad thing, because it uses my hosts file which only contains aliases of my local host (which is NOT running an NFS server, mind you). As a result, I get all kinds of errors about being unable to mount these hosts every time I run an ls in /net.

Notice: I'm not using --ghost, and yet it enables it by default. Arch confirms this on their wiki. This is extremely annoying, how do I disable ghosting? Google has failed me horribly, any insight is appreciated. Thanks.

share|improve this question

1 Answer 1

Edit /etc/conf.d/autofs and change or add the following

BROWSE_MODE="no"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.