Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Currently, I have to disconnect and connect again to use the internet for my Linux computer. It works fine for my tablet.

Do you know what could be the reason for that?

When I use the internet for more than a minute or so it simply doesn't work any more.

I am connected without a wire.

$ cat /etc/issue
Linux Mint 16 Petra \n \l
$ uname -a
Linux pc08 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
$ ifconfig
eth0      Link encap:Ethernet  HWaddr e8:40:f2:93:ff:ab  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6760 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6760 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:534518 (534.5 KB)  TX bytes:534518 (534.5 KB)

wlan0     Link encap:Ethernet  HWaddr 9c:b7:0d:f1:35:65  
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::9eb7:dff:fef1:3565/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:58102 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40615 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:63722853 (63.7 MB)  TX bytes:6852895 (6.8 MB)
$ traceroute 4.2.2.2
traceroute to 4.2.2.2 (4.2.2.2), 30 hops max, 60 byte packets
 1  192.168.1.1 (192.168.1.1)  13.115 ms  13.090 ms  13.069 ms
 2  * * *
 3  te-0-1-0-5-sur01.pittsburgh.pa.pitt.comcast.net (68.85.234.9)  180.382 ms  180.372 ms  180.356 ms
 4  162-151-21-129-static.hfc.comcastbusiness.net (162.151.21.129)  179.660 ms te-0-10-0-13-ar03.pittsburgh.pa.pitt.comcast.net (69.139.168.57)  174.513 ms te-0-8-0-12-ar03.pittsburgh.pa.pitt.comcast.net (68.85.75.189)  179.609 ms
 5  he-4-14-0-0-cr01.newyork.ny.ibone.comcast.net (68.86.94.185)  186.009 ms  186.002 ms  185.987 ms
 6  ae12.edge1.NewYork2.level3.net (4.68.127.1)  185.288 ms  54.871 ms  81.634 ms
 7  vlan51.ebr1.NewYork2.Level3.net (4.69.138.222)  103.096 ms  173.070 ms vlan52.ebr2.NewYork2.Level3.net (4.69.138.254)  173.044 ms
 8  ae-48-48.ebr2.NewYork1.Level3.net (4.69.201.37)  173.010 ms ae-47-47.ebr1.NewYork1.Level3.net (4.69.201.45)  172.915 ms  172.908 ms
 9  ae-62-62.csw1.NewYork1.Level3.net (4.69.148.34)  172.821 ms ae-92-92.csw4.NewYork1.Level3.net (4.69.148.46)  172.947 ms ae-91-91.csw4.NewYork1.Level3.net (4.69.134.78)  171.584 ms
10  ae-2-70.edge2.NewYork1.Level3.net (4.69.155.80)  172.802 ms  172.808 ms ae-1-60.edge2.NewYork1.Level3.net (4.69.155.16)  172.732 ms
11  b.resolvers.Level3.net (4.2.2.2)  172.808 ms  172.760 ms  47.988 ms
$ lspci | grep -i ethernet
03:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
share|improve this question

1 Answer 1

I have been hit by this before. It seems that some wireless cards don't play well with 802.11n on *nix. The answer (if this is indeed your problem), as explained here for example, is to disable 802.11n altogether:

echo "options iwlagn 11n_disable=1" | sudo tee /etc/modprobe.d/iwlagn.conf
sudo modprobe -rf iwlagn
sudo modprobe -v iwlagn

To find out what type of wireless card you have:

lspci | grep -i ethernet
share|improve this answer
    
When I execute the first command I get bash: /etc/modprobe.d/iwlagn.conf: Permission denied –  moose Jun 1 at 20:09
    
@moose Please see the updates after Stephane's edit. I carelessly copied the command from the referenced link without checking it for correctness. Also, are you sure you have sudo configured properly? –  Joseph R. Jun 1 at 21:05
    
The file iwlagn.conf didn't exist. So I've created it and I've executed sudo modprobe -rf iwlagn after that. I got FATAL: Module iwlagn not found. –  moose Jun 1 at 21:33
    
See askubuntu.com/q/285567/10425 –  moose Jun 1 at 21:33
    
I show this same thing in these A's as well: here, here, and here –  slm Jun 1 at 21:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.