Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am setting up Arcade Puppy http://scottjarvis.com/page105.htm on an old Dell GX50 PC.

Instead of using a PS2 style keyboard which I don't have I opted for a low profile generic USB keyboard.

The problem is that once installed to the hard disk the GRUB boot menu does not recognize the USB Keyboard so I cannot choose the boot option to start Linux, also there isn't the normal default timeout setup.

The USB keyboard works the BIOS settings fine and worked okay when booting off the live CD to install Linux.

Has anyone got any suggestions or will I be forced to find a PS2 keyboard?

share|improve this question
3  
Is this grub legacy or grub 2? Googling suggests this probably a bios problem. Can you list your current setting assocated with USB? Is there any setting like "enable IRQ for USB"? –  Faheem Mitha May 17 '11 at 16:17
add comment

1 Answer

up vote 7 down vote accepted

I had the same problem with my wireless keyboard (and running Puppy too, even if it's not related...) you have to enable in your BIOS USB Device Legacy Support.

Find it in some submenu, for example Integrated Peripherals.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.