Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've added a new man page directory

/usr/local/share/man/man1b

which contains files like e.g.

troff.1b

In /etc/man.conf I added

_subdir ...some names... man1b
_default /usr/{share,X11R7,X11R6,pkg,local,local/share}/man/
local /usr/local/share/man/
1b {cat,man}1b

man -p prints

...
/usr/local/share/man/man1b

But if I input

man 1b troff

I get the error message

man: no entry for troff in the manual.

(I can't use man troff since groff is installed too with a man page elsewhere in cat1.)

How can I add the man path correctly?

PS: If I rename the file to troff.1 then man 1b troff works. But I thought that the category can also be the file name extension. Could it be a bug of NetBSD (file name troff.1b works in OpenBSD and Linux)?

share|improve this question

1 Answer 1

You may need to update your MANPATH environment variable, at least that is what I did in this situation.

$ export MANPATH=/usr/local/share/man/

From the man page (for man):

   MANPATH
          If MANPATH is set, man uses it as the path to search
          for manual page files.  It overrides the configuration
          file and the automatic search path, but is overridden by
          the -M invocation option. See SEARCH PATH FOR MANUAL PAGES.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.