Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am on Fedora 20. I am trying to make gnome-terminal. The automake does not find certain packages. I do not understand why.

Here is the part I do not understand.

checking which gtk+ version to compile against... 3.0
checking for TERM... no
configure: error: Package requirements (vte-2.91 >= 0.37.0
   glib-2.0 >= 2.40.0
   gio-2.0 >= 2.33.2
   gtk+-3.0 >= 3.9.9
   gsettings-desktop-schemas >= 0.1.0
   dconf >= 0.14.0
   uuid
    x11) were not met:

No package 'vte-2.91' found
Requested 'glib-2.0 >= 2.40.0' but version of GLib is 2.38.2
No package 'uuid' found

-- No page 'vte-2.91' found. Is it looking for package vte-2.91 or package vte? I have vte installed, but not package vte-2.91. Fedora names the package vte. What am I to do?

Current thoughts: I need to download the source for vte version 2.91 and compile.

-- No package 'uuid' found. When I attempt to install uuid, yum install says the package is installed.

# yi is an alias for yum install 
me $ yi uuid.i686  uuid-devel.i686
[sudo] password for me: 

Loaded plugins: langpacks, refresh-packagekit
Package uuid-1.6.2-21.fc20.i686 already installed and latest version
Package uuid-devel-1.6.2-21.fc20.i686 already installed and latest version
Nothing to do
me $ 

How do I fix the uuid problem?

share|improve this question

migrated from stackoverflow.com May 27 at 15:30

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 1 down vote accepted

Every library is usually split into serveral packages such as:

foo       #the library
foo-bin   #binaries used by foo
foo-dbg   #debug symbols used by foo
foo-dev   #development stuff used by foo
foo-devel #development stuff used by foo

When you compile any software the respective development files of all dependent libraries need to be installed such as libvte-devel. Ubuntu and Debian based systems use the suffix -dev but Fedora uses the suffix -devel. But its basically the same.

On my system I have installed both libvte-2.90-dev and libvte-dev. If you checked out the lastest version from git, then its well possible that your system does not match the necessary requirements since the required packages are not available. In that case you either need to manually install the necessary libraries plus their development files or you can resort to jhbuild, a build system developed by gnome that can help you find and build are the dependencies.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.