Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

It seems that the eXpert mode in fdisk is no longer available. When I try sudo fdisk -x, terminal returns "fdisk: invalid option -- 'x'" I have fdisk from util-linux 2.24.1 Is this a "feature"?

share|improve this question
    
What feature from eXpert mode you are missing ? –  SHW May 22 at 6:36
    
And in which version did you have a commandline option to directly go to expert mode? As far as I can remember you always needed to input x to the command prompt once started to get there. –  Anthon May 22 at 6:54

1 Answer 1

up vote 0 down vote accepted

The x option is available only in interactive mode not as an parameter to fdisk command. For example:

sudo fdisk /dev/sda

Then press x at the Command (m for help): and the prompt should change to:

Expert command (m for help):

I'm using same version of fdisk.

fdisk -v
fdisk from util-linux 2.24.1
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.