Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm currently using Ubuntu 10.10 and Netbeans 7.0 and I can't type accented letters with dead keys any more. It's not a version specific problem seems it's related with Swing since I've got the same problem with older version of Netbeans and OS...

When I type '+a on any app on Linux I get a á vowel. All Linux apps are working fine, but Netbeans doesn't. When I type '+a on Netbeans I get a a vowel (no accent). I cant type quotes and double quotes either.

But I got accents on Netbeans using the right Alt key. (that's not what I want)

At terminal I got the following locale:

LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=
share|improve this question
    
That effect of '+ would be an input method. Input methods are processed by each application, so whether they work depends on what libraries the application uses. I don't know what input method uses '+ or whether Netbeans can be made to use it. –  Gilles May 11 '11 at 21:15
    
I'm not typing the plus "+" key..... I tried to explain the keystrokes eg: "'" + "a" = "á" understand it now? –  AndreDurao May 15 '11 at 23:27
    
Ah, I get it. It wasn't clear at all in your original post, lacking both the formatting (kind of hard to find in the documentation, I admit) and the standard terminology “dead keys”. –  Gilles May 16 '11 at 6:40
add comment

1 Answer

I think I've just found the fix for the same problem, thanks to [this answer] (http://devnet.jetbrains.com/message/5485348;jsessionid=AC90E67E77944B70A337D368B22A788A#5485348). Briefly: seems to be a problem with ibus. I've tried both to launch the java app (in my case freemind) with XMODIFIERS="" freemind and setting up ibus with ibus-setup and now I can write accented vowels (using deadkeys in the ES keyboard).

Hope it helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.