Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

log level is present and set to three. However I don't see it when I do a testparm

and I get next to no logs (I can see restarts and about it not being able to connect to cupsd) which doesn't seem like log level is anywhere close to three, but nothing more shows up regardless of what log level is set to in smb.conf.

This isn't a terribly complicated problem but I can't figure out a way around it.

share|improve this question
    
What's the version of samba? What OS? Set the log level to 5 and see if you notice a trace like INFO: Current debug levels:. Also, from the indentation of your grep seem log level is under some other [section] comment the current log level and move it under [global] (also log file) –  Alex May 16 at 22:29
    
testparm -v show your current printing? –  Alex May 16 at 22:48

1 Answer 1

up vote 2 down vote accepted
+50

YMMV but with my version of samba (3.6.23) setting the log level works.

[global]
log level = 10

From the log.smbd:

[2014/05/16 17:10:23,  5] ../lib/util/debug.c:330(debug_dump_status)
  INFO: Current debug levels:
    all: 10

However, you cannot use testparm to test this because it forces the log level to 2. From the source (./source3/utils/testparm.c):

370 lp_set_cmdline("log level", "2")

In fact it looks like many of the utilities override the log level. I don't know why.

Edit: Try setting it to 10.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.