Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently installed Puppy Linux on a USB stick using the Universal USB Installer, but I have not being able to boot from it. My notebook came with Windows 8 and had the secure boot activated at UEFI. I disabled the secure boot option, but I am still not able to boot from the USB stick (it is not being shown in the list of bootable devices).

Interestingly, a live USB with certain Linux distros are recognized on my computer, such as Linux Mint Cinnamon and Ubuntu. But others, such as Puppy, Zorin, Elementary OS and Mint MATE are not working.

Basically all advice I found online is to disable the secure boot option, which I already did. Is there anything else I can do in order to boot from my usb stick?

share|improve this question

1 Answer 1

You need a full shutdown, because you use Windows 8. Maybe you must disable the hybrid boot: http://www.howtogeek.com/129021/how-to-do-a-full-shutdown-in-windows-8-without-disabling-hybrid-boot/

Also look at this: http://puppylinux.org/wikka/UEFI

I hope I can help you...

share|improve this answer
    
hmm, I searched that link and it doesn't mention UEFI nor EFI at all. I had no problems installing Puppy on a USB stick, my problem was to make my UEFI boot recognize it and boot from it. –  gilberto.agostinho.f Aug 27 at 19:27
    
You need a full shutdown, because you use Windows 8. You must disable the hybrid boot: howtogeek.com/129021/… –  linuscl Aug 28 at 6:54
1  
Thanks for providing an answer. Please bear in mind that answers should stand on its own, which is why posting just a link is bad. Please put the relevant part here. Also if you have doubts if your approach answers the question, consider adding a comment to clarify the issue and then answer the question. –  k0pernikus Aug 28 at 11:05
    
@gilberto.agostinho.f : I hope I've solved your problem. If you have more questions or problem you can write them here. –  linuscl Aug 28 at 11:32
    
@k0pernikus : I update my answer... –  linuscl Aug 29 at 11:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.