Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

On an ASUS r510l or x550l laptop the touchpad is not working. I run Arch Linux, with kernel 3.14.3-2, but I also tried it in Ubuntu 12.04, Ubuntu 14.04, Debian Jessie and Fedora. This is what I get from xinput:

$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Logitech Wheel Mouse                 id=14   [slave  pointer  (2)]
⎜   ↳ USB_PS2 Optical Mouse                     id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam                      id=10   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]

It gets recognized as a PS/2 Logitech Wheel Mouse, and the psmouse module is loaded, but the touchpad doesn't work, dmesg keeps showing the same message over and over:

psmouse serio4: Failed to enable mouse on isa0060/serio4

And using hwinfo it also appears as a mouse:

$ hwinfo
PS/2 00.0: 10500 PS/2 Mouse
  [Created at input.249]
  Unique ID: AH6Q.U5GX9Ignjc0
  Hardware Class: mouse
  Model: "PS/2 Logitech Wheel Mouse"
  Vendor: 0x0002 
  Device: 0x0001 "PS/2 Logitech Wheel Mouse"
  Compatible to: int 0x0210 0x0003
  Device File: /dev/input/mice (/dev/input/mouse1)
  Device Files: /dev/input/mice, /dev/input/mouse1, /dev/input/event15, /dev/input/by-path/platform-i8042-serio-4-event-mouse, /dev/input/by-path/platform-i8042-serio-4-mouse
  Device Number: char 13:63 (char 13:33)
  Driver Info #0:
    Buttons: 3
    Wheels: 0
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
    Config Status: cfg=new, avail=yes, need=no, active=unknown

I tried several things, like installing the ALPSv7 module or an elantech module, and nothing worked. I posted this on the Arch forum (https://bbs.archlinux.org/viewtopic.php?id=181048) and so far I haven't got any information. I found other people having a similar problem with another ASUS model here: Touchpad not recognized on linux (ASUS R751LB)

But I'm not sure if it is related, since mine gets recognized (only as a mouse).

EDIT: I have updated to kernel 3.14.6 and it is still not solved. If someone knows an easy guide to kernel drivers I can try to take a further look.

Seems a generalized bug of various Asus models:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1325881

But so far there isn't a solution.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

there's a workaround given here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1314198/comments/31

no full support of the touchpad, but at least... go ahead & see, if it'll work for you as well!

share|improve this answer
    
In the future, it's a good idea to add the important bits from a link if it doesn't take too much space to do so (and it would only be a couple of lines for this case). –  HalosGhost Jun 23 at 20:46
    
Thank you! The workaround worked for me, at least I can use the touchpad in the meanwhile. Anyway, if someone has some information about how could I help to debug or fix this, I'll be happy to help. –  claptrap Jun 23 at 22:29

Hans de Goede is currently taking care of debugging this problem on Redhat's bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1110011

This is currently the only place to look for news on this matter.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.