Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In order to resize my boot partition I had to recreate my swap partition. After this systemd does not seem to be able to start.

screenshot of boot

I am new to Fedora/systemd and don't quite understand where I could tell systemd to ignore the now different UUID of the partition.

What I already did is booting a RescueCD, chrooting into my system, commenting the appropriate line in /etc/crypttab and then recreating the initrd with dracut --force --kver 3.14.3-200.fc20.x86_64

The screenshot shows the situation after these steps. How do I get my system to boot properly again?

share|improve this question
Did you change the UUID of the partition in /etc/fstab? – jayhendren May 13 '14 at 16:47
I just did (commented the line) and recreated the initrd and the problem remains. It still says "Timed out waiting for device dev-disk-by\x2duuid-b4b596..." – problemofficer May 13 '14 at 17:04
It was the kernel boot option. It contained the swap partition as a hardcoded parameter. – problemofficer May 13 '14 at 20:32

I didn't realize that boot menu entries in /boot/grub2/grub.cfg contained hardcoded parameters for swap partitions. One of them was rd.luks.uuid=luks-b4b59673-e85b-4529-840f-a9843a27a121 which corresponds to the old swap partition.

To properly boot I had to press e in the grub boot menu and then to manually remove the parameter from the line starting with linux. Then this modified menu entry can be booted by pressing F10.

After successful boot I edited /etc/default/grub and removed the parameters. Then I updated the grub configuration with # grub2-mkconfig -o /boot/grub2/grub.cfg.

Also don't forget to adjust /etc/crypttab and /etc/fstab.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.