Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have problem when i send a mail to example@orbialia.es for example2@orbialia.es My emails has bounced for this error: status=bounced (mail for orbialia.es loops back to myself)

May  9 09:33:58 ns3285243 postfix/smtpd[1606]: connect from localhost.localdomain[127.0.0.1]
May  9 09:33:58 ns3285243 postfix/smtpd[1606]: 1EF6FA1DB9: client=localhost.localdomain[127.0.0.1]
May  9 09:33:58 ns3285243 postfix/cleanup[1584]: 1EF6FA1DB9: message-id=<004801cf6b58$a6516540$f2f42fc0$@orbialia.es>
May  9 09:33:58 ns3285243 postfix/qmgr[1575]: 1EF6FA1DB9: from=<jonatan.soler@orbialia.es>, size=7184, nrcpt=1 (queue active)
May  9 09:33:58 ns3285243 postfix/smtpd[1606]: disconnect from localhost.localdomain[127.0.0.1]
May  9 09:33:58 ns3285243 amavis[15721]: (15721-16) Passed CLEAN {RelayedInbound}, [79.145.170.251]:1991 [79.145.170.251] <jonatan.soler@orbialia.es> -> <consultanos@orbialia.es>, Queue-ID: 9D0DCA1DB4, Message-ID: <004801cf6b58$a6516540$f2f42fc0$@orbialia.es>, mail_id: 8JHrgdOkE3Pw, Hits: -0.999, size: 6675, queued_as: 1EF6FA1DB9, 26690 ms
May  9 09:33:58 ns3285243 postfix/smtp[1588]: 9D0DCA1DB4: to=<consultanos@orbialia.es>, relay=127.0.0.1[127.0.0.1]:10024, delay=28, delays=1/0.02/0.01/27, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 1EF6FA1DB9)
May  9 09:33:58 ns3285243 postfix/qmgr[1575]: 9D0DCA1DB4: removed
May  9 09:33:58 ns3285243 postfix/smtp[1607]: 1EF6FA1DB9: to=<consultanos@orbialia.es>, relay=none, delay=0.11, delays=0.09/0.02/0/0, dsn=5.4.6, status=bounced (mail for orbialia.es loops back to myself)
May  9 09:33:58 ns3285243 postfix/cleanup[1584]: 42EC4A1DB4: message-id=<20140509073358.42EC4A1DB4@rentabiliza.net>
May  9 09:33:58 ns3285243 postfix/bounce[1608]: 1EF6FA1DB9: sender non-delivery notification: 42EC4A1DB4
May  9 09:33:58 ns3285243 postfix/qmgr[1575]: 42EC4A1DB4: from=<>, size=9465, nrcpt=1 (queue active)
May  9 09:33:58 ns3285243 postfix/qmgr[1575]: 1EF6FA1DB9: removed
May  9 09:33:58 ns3285243 postfix/smtp[1607]: 42EC4A1DB4: to=<jonatan.soler@orbialia.es>, relay=none, delay=0.05, delays=0.04/0/0/0, dsn=5.4.6, status=bounced (mail for orbialia.es loops back to myself)
May  9 09:33:58 ns3285243 postfix/qmgr[1575]: 42EC4A1DB4: removed

This is my postfix config

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
inet_interfaces = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
milter_default_action = accept
milter_protocol = 2
mydestination = localhost, ns3285243.ip-5-135-177.eu
myhostname = rentabiliza.net
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
non_smtpd_milters = inet:localhost:8891
policy-spf_time_limit = 3600s
readme_directory = no
recipient_delimiter = +
relayhost =
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_milters = inet:localhost:8891
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination check_policy_service unix:private/policy-spf
smtpd_sasl_auth_enable = yes
smtpd_sasl_path = private/auth
smtpd_sasl_type = dovecot
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/ssl/certs/dovecot.pem
smtpd_tls_key_file = /etc/ssl/private/dovecot.pem
smtpd_use_tls = yes
virtual_alias_domains = mysql:/etc/postfix/sql-domain-aliases.cf
virtual_alias_maps = mysql:/etc/postfix/sql-aliases.cf, mysql:/etc/postfix/sql-domain-aliases-mailboxes.cf, mysql:/etc/postfix/sql-email2email.cf, mysql:/etc/postfix/sql-catchall-aliases.cf
virtual_mailbox_domains = mysql:/etc/postfix/sql-domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/sql-mailboxes.cf
virtual_transport = lmtp:unix:private/dovecot-lmtp

I use virtual domains/users in a mysql database

hostname: ns3285243.ip-5-135-177.eu hostname -f: ns3285243.ip-5-135-177.eu

/etc/hosts

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
5.135.177.115           ns3285243.ip-5-135-177.eu       ns3285243
2001:41D0:8:B873::1     ns3285243.ip-5-135-177.eu       ns3285243

# The following lines are desirable for IPv6 capable hosts
#(added automatically by netbase upgrade)

::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

When i try to send mail to gmail.com to destination it recieve the email succesfully

If i put orbialia.es to mydestination i recieve this:

May  9 09:47:28 ns3285243 postfix/smtpd[2601]: NOQUEUE: reject: RCPT from 251.Red-79-145-170.dynamicIP.rima-tde.net[79.145.170.251]: 550 5.1.1 <consultanos@orbialia.es>: Recipient address rejected: User unknown in local recipient table; from=<jonatan.soler@orbialia.es> to=<consultanos@orbialia.es> proto=ESMTP helo=<50l3rport>

i have multiple virtual domains. How can resolve it?

share|improve this question
    
Is the DNS (MX) record for orbialia.es pointing to your postfix server? Is your postfix server configured to handle mail for orbialia.es? –  clement May 9 at 8:26
    
Yes, orbialia.es point to my postfix server and i configured it with dkim, spf...etc –  50l3r May 9 at 8:28
    
what is the output postmap -q orbialia.es mysql:/etc/postfix/sql-domains.cf and postmap -q orbialia.es mysql:/etc/postfix/sql-domain-aliases.cf ? –  masegaloeh May 9 at 9:11
    
You didnt answer my second question yet. @masegaloeh too asked the same in a different way. –  clement May 9 at 10:01
    
The error is caused by a inactive domain in mysql database. When i execute this command postmap -q orbialia.es mysql:/etc/postfix/sql-domains.cf Doesn' retrieve me the domain beacause it's marked as inactive. I activate my domain in mysql and works fine. Write an answer and i'l mark this as solved. Noob problem jeje –  50l3r May 9 at 10:39

1 Answer 1

up vote 1 down vote accepted

From comment:

The problem in this case is that the domain has not been marked as active, so when mysql is queried for active domains this one is not returned.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.