Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I was learning to configure a Debian server and familiarising myself with the common command lines.

However, after executing the reboot command in SSH, my subsequent SSH connections were refused and I have total no access to the server.

I was able to ping the server. I attempted to reboot through the Google cloud interface too, however I was still unable to connect successfully.

Having this as a cloud server, I do not have any physical access to the server. The solution that I seem to see are to reconfigure the SSH settings which I can't without logging in.

What are the possible alternatives I have now or recreating a new instance is the only solution?

share|improve this question
    
be prepared for the fact that you might have to redo your server from scratch....baring any help that the google cloud server people may be able to provide you. –  mdpc May 9 at 1:08
    
@mdpc thanks for your reply. i am pretty much ready to redo the server. but my main concern is how can i avoid such problems in the future although reboot doesn't occur often but may be still required at times. –  toffee.beanns May 9 at 1:23

1 Answer 1

I think Google gives a quite a comprehensive list of solutions for troubleshooting SSH errors, please refer here.

IMO, you may have incorrectly set up SSH keys, or there are misconfigured iptables.

share|improve this answer
    
hey delta24, thanks for your answer. I am still testing out the server, but seems like i got stucked at one part of the solution list you provided. I ran the command to add the ssh rule to the firewall and tried to do a netcat test to see the banner. However, nothing came out. There was no further instructions to which I could try out. Could you help me out? Appreciated! –  toffee.beanns May 9 at 13:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.