Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

A small introduction. I have a SMTP server ( Haraka - http://haraka.github.io/ ) on port 25 and a local postfix server on port 9267. I intercepts mails in Haraka and then I send them to my postfix server. I can see the mails received using mail -u username command but I want to use a email client(Thunderbird) to have access to them. I've created an account in Thunderbird via this http://askubuntu.com/questions/192572/how-read-local-email-in-thunderbird , but without any result and I think the problem is the postfix server configuration. Here is my postfix main.cf file .

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache


#transport test
#transport_maps = hash:/etc/postfix/transport

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mydomain.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = mydomain.com, localhost.mydomain.com, localhost
relayhost = 
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all

I appreciate any help.

share|improve this question
    
I think I found the problem. I should use dovecot or something similar. –  intenesi May 8 at 13:02
    
No you need not. If you can access mails using mail command, then there should be no issue with postfix. You should locate your mail file, where postfix is writing the mail to. –  clement May 8 at 13:41
    
Ok, So I know there are 2 mail locations , one being /var/mail and the other one /var/spool/mail. In Thunderbird, at Server Settings - > Local Directory , I've put the first path without any result(no email showing). If I try to put the /var/spool/mail path , the setting goes back to /var/mail. Does anybody know why? –  intenesi May 8 at 14:08
    
This should help commons.lbl.gov/display/~jwelcher@lbl.gov/… –  clement May 8 at 14:34
    
If I open that folder , it gives me the mails of my main account I have set up( like intenesi@gmail.com, btw it's not my address) but I have an account created for the mails that are landing in my local postfix , like test@localhost.com and I want to open this mails , not the ones from gmail. If you dont understand, I want to send mails from gmail and receive them in postfix, where I'd like to see them via Thunderbird. –  intenesi May 9 at 6:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.