Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to install rtorrent as a client (NOT SeedBox). I tried the following command:

yum install rtorrent

I get following message:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.iweb.ca
 * extras: centos.mirror.iweb.ca
 * updates: centos.mirror.netelligent.ca
Excluding Packages in global exclude list
Finished
Setting up Install Process
No package rtorrent available.
Nothing to do

I think it's because I do not have rtorrent at my repository. What should I do to add rtorrent to my repository? I tried yum update without any success.

share|improve this question
add comment

migrated from serverfault.com May 8 '11 at 14:49

This question came from our site for professional system and network administrators.

2 Answers

The reason you can't find it in the stock RPM repository that comes with CentOS is that rtorrent is traditionally a desktop application even though it is command line based. CentOS is a close of Red Had Enterprise Linux which does not include applications like rtorrent. A quick search online and I couldn't find any third party repositories for CentOS that included rtorrent.

My personal suggestion is to use Fedora, which is still based on the Red Hat architecture but includes a much wider range of packages including rtorrent.

share|improve this answer
add comment

Because you did not mention it, I am assuming you are on CentOS 5.

An old version of rtorrent can be found in the EPEL repository. I looked up the package here and found rtorrent version 0.7.8. The current version number is 0.8.7. The Fedora Project has instructions on installing the EPEL repository here.

If you want the latest version, you will need to compile it from source from their website.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.