Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Due to the lack of security with standard vino server, I switched to use x11vnc on my linux (with Xubuntu 14.04) box and SSVNC on the windows side.

With vino, cut and paste from windows to Linux and windows, in the two directions, was flaky(1) but when it worked, it worked for every program; I could use the vim register "+ without problem. I run(2)

autocutsel -fork 

normally so that the "middle click" and ctrl-c/v selections are the same.

Now that I use x11vnc (called with: x11vnc -forever -repeat -safer -usepw -ssl -autoport 6000) to have a safe, encrypted connection, a problem arose:

  1. I can copy on windows and paste in the remote linux terminals, libreoffice etc. without any problem, in both directions.

  2. In vim, or gvim, any attempt to paste with "+p or "*p says E353: Nothing in register *

  3. Again in vim or gvim, the other way around does work: if I "+yy then I can paste the thing on the Windows side.

As anyone any clue about this problem? The strange thing is that paste works everywhere I checked but in vim...

Package                 Installed       Previous        Now             State
=======================-===============-===============-===============-=====
vim                     2:7.4.052-1ubuntu3  2:7.4.052-1ubuntu3  2:7.4.052-1ubuntu3  install
vim-gnome               2:7.4.052-1ubuntu3  2:7.4.052-1ubuntu3  2:7.4.052-1ubuntu3  install

Footnotes:

(1) can't find the bug now --- it is reported. It stops working after a while.

(2) I tried with and without. No changes.

share|improve this question
    
I had many problems with x11vnc related to different language locales on host and client, especially when controlling vmware guests through vnc on the server. I finally 'solved' it by installing a nomachine server on the host system. I know that this is probably not the solution you have in mind, but nomachine and nxclient is both secure, very fast and everything is tunneled through ssh. –  Floyd Oct 10 at 15:27
2  
I don't use vnc, but I fixed all my problems with clipboard interoperability between vim and OSes by: (1) using set clipboard=unnamedplus in every linux I use (2) alias vim='gvim -v' in my .bashrcs (to work around certain distributions compiling vim without X clipboard support) (3) set clipboard=unnamed in windows. Hope it helps. –  Patryk Obara Nov 26 at 20:25
    
@PatrykObara will try... next time I have to use a windows PC. I have a Linux only setup now and no problems... Thanks. –  Rmano Nov 26 at 20:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.