Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

NOTE: I'm very new to yum/rpm, but am familiar with Linux.

I'm trying to compile Awesome on CentOS 6.5 using rpmbuild. I found SRPMs for Fedora Core and am trying to rebuild them on my CentOS install but am running into dependency issues I was hoping someone better versed with yum and rpm might be able to help me with.

Basically, while I've installed newer versions of packages, rpmbuild doesn't seem to detect them. Here is an example:

$ rpmbuild --rebuild xcb-util-image-0.3.9-2.fc19.src.rpm 

Installing xcb-util-image-0.3.9-2.fc19.src.rpm
warning: InstallSourcePackage at: psm.c:244: Header V3 RSA/SHA256 Signature, key ID fb4b18e6: NOKEY
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
error: Failed build dependencies:
    pkgconfig(xcb-util) >= 0.3.8 is needed by xcb-util-image-0.3.9-2.el6.x86_64

But as you can see here, I clearly have xcb-util > 0.3.8 installed:

$ sudo yum list installed | grep xcb-util                  
xcb-util.x86_64                        0.3.6-1.el6               @UIedited_0/6.5
xcb-util.x86_64                        0.3.9-2.el6               installed

I tried removing the older version of xcb-util but there are too many packages that depend on that.

Similar issue with building awesome when it comes to cmake:

$ rpmbuild --rebuild awesome-3.5.1-2.fc18.src.rpm
Installing awesome-3.5.1-2.fc18.src.rpm
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
error: Failed build dependencies:
    cmake >= 2.8.0 is needed by awesome-3.5.1-2.el6.x86_64
    lua-ldoc is needed by awesome-3.5.1-2.el6.x86_64
    pkgconfig(libev) is needed by awesome-3.5.1-2.el6.x86_64
    pkgconfig(xcb-util) >= 0.3.8 is needed by awesome-3.5.1-2.el6.x86_64
    pkgconfig(xcb-keysyms) >= 0.3.4 is needed by awesome-3.5.1-2.el6.x86_64
    pkgconfig(xcb-icccm) >= 0.3.8 is needed by awesome-3.5.1-2.el6.x86_64
    pkgconfig(xcb-image) >= 0.3.0 is needed by awesome-3.5.1-2.el6.x86_64
    pkgconfig(cairo-xcb) is needed by awesome-3.5.1-2.el6.x86_64
    pkgconfig(libstartup-notification-1.0) >= 0.10 is needed by awesome-3.5.1-2.el6.x86_64
    pkgconfig(libxdg-basedir) >= 1.0.0 is needed by awesome-3.5.1-2.el6.x86_64
    lua-lgi is needed by awesome-3.5.1-2.el6.x86_64
$ which cmake
/usr/bin/cmake
$ cmake --version
cmake version 2.8.11.2
$ sudo yum list installed | grep cmake
cmake28.x86_64                         2.8.11.2-1.el6            @dell-epel

So any yum/rpm gurus out there who can point me in the right direction? I'd rather not have to build everything from source, so I was hoping to get rpmbuild working with the SRPMs.

share|improve this question
add comment

2 Answers 2

Seems that your systems has multiple versions of some packages installed. If you have the "yum-utils" package installed, try the following command to remove the older versions of those packages and then see whether the rpmbuild works:

sudo /usr/bin/package-cleanup --cleandupes
share|improve this answer
    
So if I run that command, yum wants to remove about 75 additional packages such as gdm, Thunar, gnome-desktop, etc. which depend on it. I'd like to have them just use the newer version but I'm not sure if that is possible. –  sbtkd85 May 8 at 15:30
add comment
up vote 0 down vote accepted

In case anyone else finds this, I was not able to get this working and didn't want to go down the path of compiling all the dependencies from source, so I ended up abandoning this endeavor in favor of getting my build working on Fedora 20 and installing Awesome from official repos.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.