Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install Parabola(closely related to Arch Linux). As my wireless adapter does not work with linux due to some firmware issues, I have to use a wired connection. So, while a ping to www.google.com or 8.8.8.8 works out fine, everytime I try to install the base system

packman -Sy parabola-keyring

which is used to update the keyring package during installation, before you install the base system, says network is unreachable. I tried setting up a static ip, which did not work out and in the worst case made the ping not working anymore (which I fixed by rebooting the cd) and dhcpcd, which failed to. I tried solutions I read in 3 different threads, and nothing worked (e.g. changing the interface from eth0 to my own or editing resolv.conf).

I am wondering why ping works but the network connection does not, so, any ideas?

Output of ifconfig and iproute: niinii.de/?f=niinii139939920123.jpg and niinii.de/?f=niinii139939922850.jpg

share|improve this question

closed as unclear what you're asking by Braiam, slm, Ramesh, jasonwryan, Anthon May 6 at 4:41

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What is "it"? That is, what step or tool is saying "network is unreachable"? –  HalosGhost May 5 at 22:00
    
"It" is # packman -Sy parabola-keyring which is used to update the keyring package during installation, before you install the base system. wiki.parabolagnulinux.org/… –  mü_hd May 6 at 17:55
    
Does ping still work, when you get the "network is unreachable" message? –  peterph May 6 at 20:58

1 Answer 1

Well... "network is unreachable" means that the network is actually unreachable and unless there's some firewalling going on, it's a local issue.

Assuming your network works fine, your problem is one of:

  1. Your network is not being set up, meaning that you don't have an IP address.
  2. You're missing a route for the destination network which in most cases means that you're missing the default route.

Some more info would help. Things like the output of:

ifconfig
ip route
share|improve this answer
    
Problem is, as the error comes up during installation, that I cannot copy/paste the output, put I took photos of it and uploaded them here: niinii.de/?f=niinii139939920123.jpg and niinii.de/?f=niinii139939922850.jpg. I hope that's alright, too. –  mü_hd May 6 at 18:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.