Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running Fedora 13 Linux, and sending mail to myself using mutt, and I can't seem to get procmail to run. Below is what my .procmailrc, ~/Procmail/rc.testing, and .forward files all look like. As you can see, they are very simple.

.procmailrc

HOME=/home/cory
SHELL=/bin/bash
PMDIR=$HOME/Procmail
LOGFILE=$PMDIR/pmlog
LOG="
"
LOG="My PATH is currently $PATH
My SHELL is currently $SHELL
"
VERBOSE=yes
MAILDIR=$HOME/Mail

INCLUDERC=$PMDIR/rc.testing

rc.testing

:0:
* ^Subject:.*test
IN-testing

.forward

#.forward
"|/usr/bin/procmail"

The Fedora Project documentation says that the existence of .procmailrc should "invoke Procmail whenever an MTA receives a new message." As I understand it, when I send myself a message using mutt, .procmailrc will be read by procmail and the logfile pmlog should be created in my Procmail directory.

However, this log file never gets created, so it appears that procmail is never being run!

The documentation also states "Fedora 13 provides two MTAs: Sendmail and Postfix. If both are installed, postfix is the default MTA." Since which postfix results with nothing on my machine, I assume sendmail is being used. Why doesn't sendmail invoke procmail?

share|improve this question
1  
Have you verified that procmail is installed? –  camh May 7 '11 at 3:26
    
Yes. It is installed and I can run it from the command line. –  Cory Klein May 9 '11 at 16:49
add comment

1 Answer 1

up vote 2 down vote accepted

The postfix command exists in /usr/sbin/ if Postfix is installed, and regular users do not have the /sbin/ directories in their PATH variable by default. The best way to check is by asking your package manager - in this case, by typing rpm -q postfix.

If it is installed, check the value of the mailbox_command parameter, either by looking for it in /etc/postfix/main.cf or by typing /usr/sbin/postconf mailbix_command. If that returns something other than `procmail -a "$EXTENSION" then Postfix isn't invoking procmail on local deliveries, which would be the problem.

You also should check if procmail is actually installed (binary should be in /usr/bin/procmail or you can check by rpm -ql procmail if my memory about rpm-based package management serves).

If it turns out you are using sendmail, then please for the love of all that's good and sacred, install postfix instead. Please don't make me try to remember how to edit and modify sendmail rules files...

share|improve this answer
    
A better way to check would be to see if the directory /etc/postfix/ exists. The OP is using Fedora 13, so rpm -q postfix is another way. –  Mikel May 7 '11 at 6:33
    
Thanks. Updated the response -- like I said, rpm isn't really my strong suit. –  Shadur May 7 '11 at 7:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.