Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've just installed QT 5 in Arch Linux, but only qtconfig doesn't work:

%> qtconfig
qtconfig: could not exec '/usr/lib/qt/bin/qtconfig': No such file or directory

Yes, there's no such file, not even /usr/lib/qt5/bin/qtconfig

Any ideas where to locate it? I need to adjust the font of smplayer, which is linked with QT 5 libraries now.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

qtconfig no longer exist in Qt5. Qt5 applications will use the current desktop settings by default, but it doesn't work perfectly. For instance I'm using XFCE and it doesn't automatically set the style to Gtk.

The style can be set with the -style command line option, for instance -style=gtk . Or you can use a specific Qt stylesheet with -stylesheet. You can see the available options in QApplication documentation. Also :

You can also set the style for all Qt applications by setting the QT_STYLE_OVERRIDE environment variable.

For smplayer, you can change the default font and style used in the menu Option > Preferences > Interface.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.