Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed oidentd and it is not working with ipv6s only, it works with ipv4 just fine. I have done some search on google and applied a patch on oidentd to work with ipv6 but i still cant make it to work. Here is the copy/paste.

root@mustang [~]# lsof -i -n -P | grep oidentd
oidentd 6065 nobody 6u IPv4 5906 0t0 TCP *:113 (LISTEN)
oidentd 6065 nobody 7u IPv6 5907 0t0 TCP *:113 (LISTEN)

telnet ::1 113
Trying ::1...
Connected to ::1.
Escape character is '^]'.

I also tried changing the value 0 to 1 in /proc/sys/net/ipv6/bindv6only still doesn't help. I even tried editing the setting in /etc/init.d/oidentd to execute oidentd with -a :: still nothing. All of my users are getting ~ symbol ifront of their ident. Here is one example

Nick is ~d34m0n@2607:5300:60:5177::21e3:4232 * ...

what am I missing? it's been a week and i am still scratching my head.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.