Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently decided to try out zsh, but for some reason I cannot open Vim in a zsh shell. Currently, my default shell is bash. If I open up a terminal window, then run zsh to enter a zsh shell, I have no problems opening up Vim.

The problem comes when I run the chsh -s /bin/zsh command to try and change my default shell to zsh. Now, when I open up a terminal window, a zsh shell opens up, but I cannot open Vim. When I try to run vim <filename>, the shell just hangs, and I cannot , , or even to quit.

I've checked my $PATH variable while I'm in the zsh shell and everything is correct. Running which vim correctly shows that Vim is in /usr/bin/vim. Currently, my .zshrc is blank. I've tried running other commands like ls, cd, less, etc, and they all work properly. As far as I can tell, Vim is the only command giving me troubles. Any insight would be much appreciated.

share|improve this question

closed as off-topic by slm, Warren Young, jasonwryan, devnull, Thomas Nyman Apr 27 at 6:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – slm, Warren Young, jasonwryan, devnull, Thomas Nyman
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I'm confused, is the issue launching vim from bash or zsh when which ever is made the default via chsh? –  slm Apr 26 at 23:18
    
The issue is after I run chsh -s /bin/zsh, then restart the terminal (quit then reopen), I cannot open vim. When I switch back to bash as my default terminal (chsh -s /bin/bash), I have no problems opening vim. Edited my main post to hopefully clarify some points. –  Cody Ma Apr 26 at 23:23
    
When you change your shell using chsh you probably should reboot and login your entire desktop using the new default shell. Also to debug it further: strace -s 2000 -m vim_wont_open.log vim to see what's going on. –  slm Apr 26 at 23:32
    
Just tried rebooting my computer after running chsh and still having the same problem. I'm on OSX and I don't think strace is a command :/ –  Cody Ma Apr 27 at 0:18
1  
OK, closing this Q as off-topic b/c of the issue that was fixed by correcting a typo. –  slm Apr 27 at 0:58

Browse other questions tagged or ask your own question.