Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

With a special combination of shell (zsh w/ syntax hightlighting), terminal (urxvt) and configuration with Xresources, I noticed a strange issue with font rendering that only seems to occur with some bold characters (AKA bold escape sequences) like the letter 'k' -- it will show up as a tall, empty vertical rectangle (see picture below):

terminal shows strange font rendering

Why does this happen?

share|improve this question
    
Post your configuration! (Especially the fonts but do post all applicable resources.) –  Gilles Apr 24 at 23:12
    
@Gilles I actually know the answer to this, but didn't realize that I had to wait to self-answer since I didn't have an account for this exchange :) (I'm only minimally active on SO) Spoiler: The culprit is the letterSpace resource being set to -1 in Xresources. –  Isaac Aggrey Apr 25 at 0:45

1 Answer 1

up vote 2 down vote accepted

The issue is due to the letterSpace configuration in the .Xresources file, which sets letterSpace to -1 (or lower) like:

! /home/username/.Xresources

URxvt*letterSpace: -1

Many users and blog posts will suggest changing the letterSpace option to -1 to adjust for kerning, but there seems to be a side effect in this situation where urxvt can't render the glyph.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.