Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've configured nm-applet to run during X login, and I've connected to my home Wi-Fi network many times. Recently it no longer tries to connect to the network after logging in. In the connection's "General" tab "Automatically connect to this network when it is available" is checked:

enter image description here

The wired network connection is also configured to connect automatically, but it's not been connected for weeks. It and the Wi-Fi are the only configured connections.

NM does try to reconnect if I disable and re-enable Wi-Fi after connecting, so at some level I guess it still knows about the auto-connect (or maybe it's just trying to get to the previous state).

When I re-enabled Wi-Fi just a few minutes ago it created a new connection with the same name as the existing Wi-Fi connection with a "-1" at the end. After deleting that connection I can no longer reproduce this behaviour.

The SSID is not hidden. I just booted, NM auto-connected after login and created another copy of the connection:

$ nmcli c
NAME                      UUID                                   TYPE              TIMESTAMP-REAL                    
Wired connection 1        6c870845-d2c0-465a-9f74-ae53ecd6ac0c   802-3-ethernet    Mon 21 Apr 2014 08:23:52 AM BST   
BTHub4-GRK6               77cfadf5-e580-411a-978b-3c1d44265373   802-11-wireless   Mon 21 Apr 2014 08:28:52 AM BST   
BTHub4-GRK6 1             858e53cc-000b-461f-b2c1-7ce3e761a833   802-11-wireless   never                             

NetworkManager is already running:

$ systemctl status NetworkManager
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
   Active: active (running) since Thu 2014-05-22 08:13:30 BST; 12h ago
 Main PID: 340 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           ├─340 /usr/bin/NetworkManager --no-daemon
           └─875 /usr/bin/dhcpcd -B -K -L -G -c /usr/lib/networkmanager/nm-dhcp-client.action wl...
share|improve this question
    
I have the same issue w/ it on my Fedora 19 laptop. It occurs when I go to work I often have to manually connect, but at home it always auto connects. –  slm Apr 21 at 0:31
    
None of the SSID's are hidden by chance? blog.nixpanic.net/2011/01/… –  slm Apr 21 at 1:04
    
Also out of curiosity can you confirm that the network shows "Auto" in the NAME column when you run nmcli c? My network though setup to auto connect does not show "Auto" here. All my other networks that do work w/ auto connecting do however show "Auto". –  slm Apr 21 at 1:16
    
Just a note, nm-applet is not there to autoconnect or anything like that, this is handled by NetworkManager which on the other hand doesn't care so much about login sessions. Which version of NetworkManager are you using? Which type of wireless authentication is used? –  Pavel Šimerda Apr 23 at 16:02
    
@slm I suspect that's been abandoned (or perhaps a distro-specific feature). I certainly never turned off the auto-connection. –  l0b0 May 22 at 19:48

1 Answer 1

Have you enabled the NetworkManager systemd service?

sudo systemctl enable NetworkManager
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.