Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have network configure:

config interface 'lan'
    option ifname 'eth2.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.2.1'
    option netmask '255.255.255.0'
    option macaddr '00:17:a5:00:07:5d'

config interface 'wan'
    option ifname 'eth2.2'

config switch
    option name 'mt762x'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'mt762x'
    option vlan '1'
    option ports '0 1 2 3 5 6t'

config switch_vlan
    option device 'mt762x'
    option vlan '2'
    option ports '4 6t'

ifconfig:

br-lan    Link encap:Ethernet  HWaddr 00:17:A5:00:07:5D  
      inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:0 (0.0 B)  TX bytes:504 (504.0 B)

eth2      Link encap:Ethernet  HWaddr 00:17:A5:70:07:44  
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:632 errors:0 dropped:440 overruns:0 frame:0
      TX packets:343 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:97202 (94.9 KiB)  TX bytes:11616 (11.3 KiB)
      Interrupt:3 

eth2.1    Link encap:Ethernet  HWaddr 00:17:A5:70:07:44  
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:0 (0.0 B)  TX bytes:504 (504.0 B)

eth2.2    Link encap:Ethernet  HWaddr 00:17:A5:70:07:44  
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I ping 192.168.2.2, which is my host.

eth2.1 tx is 12, but rx is 0.

I'm sure hardware is ok.

when i connect to port 0, host can connect the router。

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.