Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

perhaps you can help me with the following problem and make my Linux world whole again! :)

After a new installation on my old hardware, I noticed considerably worse performance, although the hardware was not altered. Overall operation seems fine. But if I start a youtube video and put it in full screen, I get horrible performance even several seconds of freeze.

Also, running e.g. wesnoth is quite slow. I used to be able to run wesnoth on the big monitor while running a video on the second monitor simultaneously with no problem at all.

My Graphics Card:

$ sudo lspci|grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Juniper XT [Radeon HD 5770]

My Screen Resolution(s): (output cropped a bit by some lower resolutions)

$ xrandr
Screen 0: minimum 320 x 200, current 3200 x 1080, maximum 8192 x 8192
DFP1 disconnected (normal left inverted right x axis y axis)
DFP2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080      60.0*+   50.0     59.9     60.1     50.0     60.0  
   1600x1200      60.0  
   [...]
DFP3 disconnected (normal left inverted right x axis y axis)
DFP4 disconnected (normal left inverted right x axis y axis)
CRT1 disconnected (normal left inverted right x axis y axis)
CRT2 connected 1280x1024+1920+0 (normal left inverted right x axis y axis)     338mm x 270mm
   1280x1024      60.0*+   75.0  
   1280x960       60.0  
   [...]

My Kernel and ATI drivers:

sys-kernel/linux-sabayon-3.12.14
x11-drivers/ati-drivers-13.12#3.12.0-sabayon

Direct rendering is enabled:

$ glxinfo | grep rendering
direct rendering: Yes

When measuring performance with glxgears:

$ glxgears
15868 frames in 5.0 seconds = 3173.469 FPS

This is my xorg.conf, presumable generated by amdcccle (which I used for configuration)

Section "ServerLayout"
    Identifier     "Main Layout"
    Screen      0  "amdcccle-Screen[1]-0" 0 0
EndSection

Section "Module"
    SubSection "extmod"
        Option      "omit xfree86-dga"
    EndSubSection
    Load  "i2c"
    Load  "ddc"
    Load  "vbe"
    Load  "dri"
    Load  "glx"
    Load  "synaptics"
EndSection

Section "ServerFlags"
    Option      "AllowMouseOpenFail" "true"
EndSection

Section "Monitor"
    Identifier   "Generic Monitor"
    HorizSync    28.0 - 80.0
    VertRefresh  43.0 - 60.0
EndSection

Section "Monitor"
    Identifier   "0-DFP2"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1920x1080"
    Option      "TargetRefresh" "60"
    Option      "Position" "0 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Monitor"
    Identifier   "0-CRT2"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1280x1024"
    Option      "TargetRefresh" "60"
    Option      "Position" "1920 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Device"

    #BusID    "PCI:01:00"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    # UseEvents is causing segmentation faults with
    # NVIDIA 6xxx, 7xxx and >=275.xx.xx drivers
    #Option "UseEvents" "True"
    Identifier  "SabayonVga0"
    Driver      "fglrx"
    Option      "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"
EndSection

Section "Device"
    Identifier  "amdcccle-Device[1]-0"
    Driver      "fglrx"
    Option      "Monitor-DFP2" "0-DFP2"
    Option      "Monitor-CRT2" "0-CRT2"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"

    #Option       "AddARGBGLXVisuals" "true"
    #Option       "RegistryDwords" "EnableBrightnessControl=1"
    Identifier "Screen 0"
    Device     "SabayonVga0"
    Monitor    "Generic Monitor"
    DefaultDepth     24
    SubSection "Display"

        #Modes      "1024x768" "800x600" "640x480"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"

        #Modes      "1024x768" "800x600" "640x480"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"

        #Modes      "1024x768" "800x600" "640x480"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "amdcccle-Screen[1]-0"
    Device     "amdcccle-Device[1]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "DRI"
    Mode         0666
EndSection

Thank you very much for helping me out with this problem!

PS: This is my first question here. Please feel free to suggest changes if my question could be optimized! Thanks! :)

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Finally Solved!

I finally got decent Performance and Dual-Head back. In short, I had to remove catalyst, the closed-source AMD/ATI driver, also named fglrx. Instead, I now use the open-source driver "readeon", which performs nicely.

Here is what I did:

CAUTION: Make sure to back-up all files that you overwrite wth these commands!

Kill fglrx with fire:

(see https://wiki.sabayon.org/index.php?title=HOWTO:_Get_AMD/ATI_or_Nvidia_Video_Cards_working_in_Sabayon#Roll_Back)

$ equo remove ati-drivers amdcccle
$ equo install xf86-video-ati
$ equo install x11-base/xorg-drivers
$ eselect opengl set xorg-x11
$ sed -i '/blacklist radeon/d' /etc/modprobe.d/blacklist.conf
$ sed -i 's/\<nomodeset\>//g' /etc/default/grub

Additionally, I had to perfom these steps:

# remove all instances of "nomodeset" from /etc/default/sabayon-grub
$ grub2-mkconfig -o /boot/grub/grub.cfg # generates a new GRUB boot configuration file (removes the kernel parameter "nomodeset")
$ rm /etc/X11/xorg.conf         # removes xorg.conf: X server does not need it anymore, in most cases

After booting, my second monitor was mirroring the first monitor. I got rid of that and configured the correct positioning and resolution with KDE's configuration program:

# Open KDE System Settings
# Klick "Hardware > Display and Monitor"
# Configure correct positioning and resolution of your Displays
# Klick "Save as Default > Safe as Default"

The result:

Now, after rebooting, I have a smooth-running KDE Dual-Head again! :)

$ glxgears
301 frames in 5.0 seconds = 60.018 FPS
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.