Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

This question already has an answer here:

I created an SSH key on my laptop using ssh-keygen and then put it on some production servers so that I don' have to type my password every time.

On some servers it is working well, but on some it's still asking for my password. Why is that? Even though the .ssh/* permissions are for the users.

PubkeyAuth is set to Yes:

RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile      .ssh/authorized_keys

ssh -vv output:

OpenSSH_5.9p1 Debian-5ubuntu1.1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to xxx.xxx.xxx.xxx [xxx.xxx.xxx.xxx] port 22.
debug1: Connection established.
debug1: identity file /home/omipenguin/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file /home/omipenguin/.ssh/id_rsa-cert type -1
debug1: identity file /home/omipenguin/.ssh/id_dsa type -1
debug1: identity file /home/omipenguin/.ssh/id_dsa-cert type -1
debug1: identity file /home/omipenguin/.ssh/id_ecdsa type -1
debug1: identity file /home/omipenguin/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH_4*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1.1
debug2: fd 3 setting O_NONBLOCK
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-rsa,ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-dss-cert-v01@openssh.com,ssh-dss-cert-v00@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: mac_setup: found hmac-md5
debug1: kex: server->client aes128-ctr hmac-md5 none
debug2: mac_setup: found hmac-md5
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 121/256
debug2: bits set: 527/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA d2:5c:eb:cf:9a:55:85:ce:a1:00:71:c8:92:bb:25:fb
debug1: Host 'xxx.xxx.xxx.xxx' is known and matches the RSA host key.
debug1: Found key in /home/omipenguin/.ssh/known_hosts:14
debug2: bits set: 540/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/omipenguin/.ssh/id_rsa (0x7fe924a9f3f0)
debug2: key: /home/omipenguin/.ssh/id_dsa ((nil))
debug2: key: /home/omipenguin/.ssh/id_ecdsa ((nil))
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/omipenguin/.ssh/id_rsa
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /home/omipenguin/.ssh/id_dsa
debug1: Trying private key: /home/omipenguin/.ssh/id_ecdsa
debug2: we did not send a packet, disable method
debug1: Next authentication method: password

File and directory permissions:

drwxrwxr-x 2 emerg wheel 4096 Apr 10 11:51 .ssh/
-rw-r--r-- 1 emerg emerg 403 Apr 10 11:51 .ssh/authorized_keys
share|improve this question

marked as duplicate by Gilles, slm, jasonwryan, Anthon, strugee Apr 11 at 6:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Do all the servers have PubkeyAuthentication set to yes? –  Jenny D Apr 10 at 9:03
1  
Please running ssh user@server -vv and provide some output. –  cuonglm Apr 10 at 9:05
1  
Please also provide relevant parts of the authentication log from the server. –  Chris Down Apr 10 at 9:14
    
It seems server setup is ok. Can you provide ls -ld .ssh and ls -l .ssh output. –  cuonglm Apr 10 at 9:16

2 Answers 2

An addition for @Jenny D's answer, from man ssh:

~/.ssh/
             This directory is the default location for all user-specific con‐
             figuration and authentication information.  There is no general
             requirement to keep the entire contents of this directory secret,
             but the recommended permissions are read/write/execute for the
             user, and not accessible by others.

~/.ssh/id_rsa
             Contains the private key for authentication.  These files contain
             sensitive data and should be readable by the user but not acces‐
             sible by others (read/write/execute).  ssh will simply ignore a
             private key file if it is accessible by others.  It is possible
             to specify a passphrase when generating the key which will be
             used to encrypt the sensitive part of this file using 3DES.

I think the permission for .ssh is original "free", but it is restricted by permission of private key file, so you can not give .ssh write permission to group or other.

share|improve this answer
    
Indeed - if the directory is writable, it doesn't help that the key file isn't. Anyone with write permissions to the directory can just delete the original key file and replace it with their own. –  Jenny D Apr 10 at 9:53
    
Of course, so I said that "restricted by permission of private key file". You can see in man page, there is no really strictness with .ssh folder. –  cuonglm Apr 10 at 9:55

Here's the culprit:

drwxrwxr-x 2 emerg wheel 4096 Apr 10 11:51 .ssh/

You're allowing anyone in the group wheel write access to your .ssh directory. This means that any member of that group could replace your authorized_keys file - so SSH refuses to trust the file.

Fix your permissions and the problem should go away.

share|improve this answer
    
Great job, you my friend have Sharp eyes. Salute you. Thanks its working now –  OmiPenguin Apr 10 at 9:39
    
Just curious, how could it work on other servers, then? –  lgeorget Apr 10 at 9:41
    
@Igeorget Maybe they have different umask so the directory was created with better permissions? Can't tell without knowing more about them. –  Jenny D Apr 10 at 9:49
    
@OmiPenguin I'm glad it works! It would also break if /home/emerg had group or other writable, even if /home/emerg/.ssh didn't. I found this out when people wanted to be able to login with ssh keys to an application user and also wanted that user's home directory writable for members of the group. Took a while to find the reason why their ssh keys didn't work, and that's why I now know to look for it... –  Jenny D Apr 10 at 10:00
    
@Igeorget, The File and Folder Perms were just like mentioned in correct answer. And on some servers permissions were given to Group wheel and others could write also. So I unset the Write permission and it started working –  OmiPenguin Apr 10 at 20:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.