Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am just trying to fix the Heartbleed bug associated with OpenSSL on Fedora Core 20. I am trying to follow the instructions as described here:

http://www.forums.fedoraforum.org/showthread.php?t=298372

That is, installing packages as follows:

yum -y install koji
koji download-build --arch=x86_64 openssl-1.0.1e-37.fc20.1
yum localinstall openssl-1.0.1e-37.fc20.1.x86_64.rpm

However, I keep on running into this error:

Error: Package: 1:openssl-1.0.1e-37.fc20.1.x86_64 (/openssl-1.0.1e-37.fc20.1.x86_64)
       Requires: openssl-libs(x86-64) = 1:1.0.1e-37.fc20.1
       Installed: 1:openssl-libs-1.0.1e-37.fc20.x86_64 (@updates)
           openssl-libs(x86-64) = 1:1.0.1e-37.fc20
       Available: 1:openssl-libs-1.0.1e-30.fc20.x86_64 (fedora)
           openssl-libs(x86-64) = 1:1.0.1e-30.fc20
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I have tried installing openssl-libs separately but I run into this error:

Error: Package: 1:cups-libs-1.7.1-8.fc20.i686 (@updates)
       Requires: libssl.so.10(libssl.so.10)
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libssl.so.10(libssl.so.10)
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libssl.so.10(libssl.so.10)
Error: Package: VirtualGL-2.3.3-2.fc20.i686 (@fedora)
       Requires: libssl.so.10(libssl.so.10)
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libssl.so.10(libssl.so.10)
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libssl.so.10(libssl.so.10)
Error: Package: 1:cups-libs-1.7.1-8.fc20.i686 (@updates)
       Requires: libcrypto.so.10
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libcrypto.so.10
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libcrypto.so.10
Error: Package: VirtualGL-2.3.3-2.fc20.i686 (@fedora)
       Requires: libssl.so.10
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libssl.so.10
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libssl.so.10
Error: Package: libssh2-1.4.3-8.fc20.i686 (@fedora)
       Requires: libssl.so.10
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libssl.so.10
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libssl.so.10
Error: Package: 1:cups-libs-1.7.1-8.fc20.i686 (@updates)
       Requires: libcrypto.so.10(libcrypto.so.10)
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libcrypto.so.10(libcrypto.so.10)
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libcrypto.so.10(libcrypto.so.10)
Error: Package: trousers-0.3.11.2-3.fc20.i686 (@updates)
       Requires: libcrypto.so.10
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libcrypto.so.10
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libcrypto.so.10
Error: Package: VirtualGL-2.3.3-2.fc20.i686 (@fedora)
       Requires: libcrypto.so.10
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libcrypto.so.10
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libcrypto.so.10
Error: Package: trousers-0.3.11.2-3.fc20.i686 (@updates)
       Requires: libcrypto.so.10(libcrypto.so.10)
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libcrypto.so.10(libcrypto.so.10)
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libcrypto.so.10(libcrypto.so.10)
Error: Package: VirtualGL-2.3.3-2.fc20.i686 (@fedora)
       Requires: libcrypto.so.10(libcrypto.so.10)
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libcrypto.so.10(libcrypto.so.10)
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libcrypto.so.10(libcrypto.so.10)
Error: Package: 1:cups-libs-1.7.1-8.fc20.i686 (@updates)
       Requires: libssl.so.10
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libssl.so.10
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libssl.so.10
Error: Package: VirtualGL-2.3.3-2.fc20.i686 (@fedora)
       Requires: libcrypto.so.10(OPENSSL_1.0.1)
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libcrypto.so.10(OPENSSL_1.0.1)
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libcrypto.so.10(OPENSSL_1.0.1)
Error: Package: libssh2-1.4.3-8.fc20.i686 (@fedora)
       Requires: libcrypto.so.10(libcrypto.so.10)
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libcrypto.so.10(libcrypto.so.10)
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libcrypto.so.10(libcrypto.so.10)
Error: Package: libssh2-1.4.3-8.fc20.i686 (@fedora)
       Requires: libcrypto.so.10
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libcrypto.so.10
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libcrypto.so.10
Error: Package: trousers-0.3.11.2-3.fc20.i686 (@updates)
       Requires: libssl.so.10
       Removing: 1:openssl-libs-1.0.1e-37.fc20.i686 (@updates)
           libssl.so.10
       Updated By: 1:openssl-libs-1.0.1e-37.fc20.1.x86_64 (/openssl-libs-1.0.1e-37.fc20.1.x86_64)
           Not found
       Available: 1:openssl-libs-1.0.1e-30.fc20.i686 (fedora)
           libssl.so.10
 You could try using --skip-broken to work around the problem

What am I missing? Thank you.

share|improve this question

migrated from stackoverflow.com Apr 9 at 22:23

This question came from our site for professional and enthusiast programmers.

2  
This question appears to be off-topic because it is about software versions, administration and patching. Server Fault has quite a few questions on the topic: serverfault.com/questions/tagged/heartbleed. –  noloader Apr 9 at 11:06
    
you may want to look at Unix & Linux. I've flagged for migration. –  strugee Apr 9 at 22:18

3 Answers 3

The patch is in Fedora 20 stable now. A simple

# yum update

as root will fix your problem, or

$ sudo yum update

If you prefer not to run around as root

And to answer the other answer above, the fix was backported from the 1.0.1g branch into 1.0.1e for Fedora. Ref here for details.

Do not forget to reboot, either the affected services, preferably the whole box. Not doing so will still leave you vulnerable.

Testing sites:

  • http://filippo.io/Heartbleed/
  • https://www.ssllabs.com/ssltest/

To put back OT: The fix above did note that if you have openssl-libs (same version), that you may have to grab those as a local compile as well.

share|improve this answer
    
This worked. Thank you. –  user1884723 Apr 11 at 3:41

I thought that 1.01e was a problem?

From Life Hacker and other sites: "The Heartbleed bug, as its now known, affects any sites and services running specific versions of OpenSSL (1.0.1 through 1.0.1f)"

share|improve this answer
    
To be fair, Thawte SSL toolbox (and likely others) still marks my site as vulnerable, even though it has been patched by Fedora. –  The Dude Apr 10 at 13:52
1  
Looks like openssl-1.0.1e-37.fc20.1 IS the right patched version accoring to this; lists.fedoraproject.org/pipermail/announce/2014-April/… –  Soren Apr 10 at 14:34
    
Someone forgot to restart the affected services (that would be me). D'oh! –  The Dude Apr 10 at 14:58

The answer is

sudo yum localinstall openssl-libs-1.0.1e-37.fc20.1.x86_64.rpm  openssl-1.0.1e-37.fc20.1.x86_64.rpm

above all on one line.

I.e. install both ssl and libs at same time and circular dependency is resolved.

Got this from https://library.linode.com/security/openssl-heartbleed

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.