Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running a fresh install of Wheezy x86 and trying to connect a Targus number pad (model AKP10US) which has the USB Vendor/Model IDs of 05A4 / 9840. (FWIW the system is also running in VirtualBox)

However the only keys on the number pad that seem to work are Enter and Back. For other keys, I see escape like looking strings or I just hear a sound (which sounds like a keyboard buffer full type sound).

For example in Terminal when pressing 0 I see ^[[2~, and when pressing . I hear the sound. (As a comparison with the number pad connected to OSX, even though OSX says Unknown keyboard I still get the correct keystrokes out. But on Windows 7 its different again and I only have workable +-/* <tab> and <enter> keys)

Dumping out dmesg I get

[  233.313462] usb 2-2: new full-speed USB device number 3 using ohci_hcd
[  233.525221] usb 2-2: New USB device found, idVendor=05a4, idProduct=9840
[  233.525221] usb 2-2: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[  233.525221] usb 2-2: Product: USB Compliant Keypad
[  233.552503] input: USB Compliant Keypad as /devices/pci0000:00/0000:00:06.0/usb2/2-2/2-2:1.0/input/input7
[  233.552669] generic-usb 0003:05A4:9840.0002: input,hidraw1: USB HID v1.10 Keyboard [USB Compliant Keypad] on usb-0000:00:06.0-2/input0

And for lsusb -v I get

Bus 002 Device 003: ID 05a4:9840 Ortek Technology, Inc. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x05a4 Ortek Technology, Inc.
  idProduct          0x9840 
  bcdDevice            1.10
  iManufacturer           0 
  iProduct                1 USB Compliant Keypad
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           34
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower               48mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      1 Boot Interface Subclass
      bInterfaceProtocol      1 Keyboard
      iInterface              0 
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.10
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      65
         Report Descriptors: 
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              13
Device Status:     0x0000
  (Bus Powered)

So it seems as if Debian has found the keyboard, but it hasn't wired it up as desired.

So what can I configure (no kernel compiling etc) to correctly enable this keyboard? Or is it actually working correctly and I just don't know it?

Edit

I just plugged in a full sized USB keyboard into the system and everything worked straight away except for the numbers of the numeric keypad. These behaved almost the same as above. However, once I pressed Numlock, even the numeric kets worked. So my guess is that the Number pad is working correctly, but that driver is not applying Numlock to the key codes coming from it.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Real D'Oh moment here

The problem was Numlock.

The solution was:

System Settings -> Keyboard -> Layout settings -> Options -> Miscellaneous compatibility options

I checked Numeric keypad keys always enter digits (as in Mac OS)

And now things work as I expected

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.