Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've been using my VPN (privateinternetaccess) for almost a year. I've been connecting through the same gateway, using the same username and password, with the same settings. Yesterday, it randomly refused to connect at home. I got to school and it worked fine, so I assumed it was an issue with their servers that was resolved. But when I got back home, it wasn't working again. I tried connecting to different locations my account has access to (Canada and various places in the US), but none of them worked.

I usually connect to the VPN with NetworkManager, and it takes about 3 seconds to connect. The weird thing is, while NetworkManager always times out when trying to connect, running "openvpn file.ovpn" on the .ovpn file provided by the VPN provider will connect, but it will take over a minute.

What could be wrong here? Just to clarify, it still works perfectly fine on my school's network, but not my home one.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.