Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I went through the Arch installation yesterday, everything seemed to be going fine but when I ran startx it gave an error(in image below)- error message when I ran startx

Is it a problem with the graphics card driver? My laptop has Intel GL40 and I've installed the xf86-video-intel driver; is it the correct one?

share|improve this question
    
What does the log file /var/log/Xorg.0.log say? –  tak Apr 29 '11 at 3:20

3 Answers 3

up vote 3 down vote accepted

Have you installed xterm and twm? It doesn't appear so from that screenshot.

Make sure you install all of the Xorg base packages:

# pacman -S xorg-server xorg-xinit xorg-utils xorg-server-utils

From the Arch Beginners' Guide

share|improve this answer
    
@jasonwryan- Yes, I've already installed those packages but still it doesn't work –  Samrat Man Singh Apr 29 '11 at 4:02
1  
The error message is pretty clear - neither package is found. Install them explicitly: # pacman -S xorg-twm xorg-xclock xterm –  jasonwryan Apr 29 '11 at 4:36
    
# pacman -S xorg-twm xorg-xclock xterm made it work. Thanks! –  Samrat Man Singh Apr 30 '11 at 6:14

To make sure that this is NOT the problem with X itself, you have to observe the below commands:

  1. X => This will start the bare X with mouse pointer. If it comes, your X is fine. Press alt+ctrl+backspace to get back to console again.

  2. Xorg -configure => Configure the xorg.conf for the underlying hardware.

  3. Xorg -config ~/xorg.conf.new => Start the X with this new config file.

Here ~ is your home directory.

This will start the X, with the configuration as per your ~/.xinitrc file. If you have the xterm, then create the ~/.xinitrc file as

$ cat ~/.xinitrc

xterm

Make this file executable.

share|improve this answer
    
In Arch, you start X with the command: startx - and Ctrl-Alt-Backspace is disabled by default... Also, he doesn't need an xorg.conf –  jasonwryan Apr 29 '11 at 9:26

Looks like you installed xorg but not a single window/desktop manager. Try this: pacman -S slim xfce4 xfce4-goodies this should install a whole bunch of stuff; normally that's annoying but in your case you want to 'catch up' your distro to all the libraries a normal desktop needs.

Once that's done, either enable slim in /etc/inittab (and disable any other session manager that's enabled, usually it's xdm by default), or I think you could also start slim as a service (you can do that in Debian, I don't have access to my Arch right now).

share|improve this answer
    
You don't need to install a display manager (Slim) or a desktop environment (XFCE) to run X... –  jasonwryan Dec 1 '11 at 17:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.