Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am currently running Ubuntu Server 12.04, but this applies to all flavours of Linux really.

This server does a bunch of things and is controlled remotely via ssh. Some time ago I have installed XFCE for those times when I didn't really feel like commandlining or to speed up some program configuration. It's off most of the time and I only launch it when I need it.

Today I installed CrashPlan to have my other computers on the network backup to the server. For those of you who don't know it, CrashPlan comes with two services, one is the actual backup engine and one is the GUI. So I installed in on the server, launched the GUI to configure it and then killed X (sudo service lightdm stop).

But now every time I try to login remotely with RDP from my Windows machine (xdrp is installed on the server) I am able to connect graphically to the server, which means that all the X-related processes are still running.

What have I forgotten? Is it possible to stop running the CrashPlan GUI service and have it never start anymore?

share|improve this question

2 Answers 2

up vote 3 down vote accepted
+50

What makes you think X-related processes are still running? When you log in remotely xrdp (re-)connects you to your GUI environment. If you don't have one running already then xrdp-sesman will cause a GUI environment to get initialized. (If you want to prevent that you could sudo service xrdp stop although it will likely come back on re-boot unless you prevent that.)

Why not just ssh into the Ubuntu server and do a ps -ef to assure yourself that no processes are running that you do not expect? In the case of CrashPlan you would see CrashPlanService all the time but you only see CrashPlanDesktop if the GUI is running.

share|improve this answer
    
It makes more sense now. I didn't know that launching xrdp recreated the GUI environment. –  user1301428 Apr 11 at 8:46
    
Right, so the GUI does not autostart (nor does the service, for that matter). Running sudo service xrdp stop closed X apparently, because I am not able to connect remotely anymore. Thank you :) –  user1301428 Apr 12 at 12:27
    
@sim below is correct "What he says isn't true that it recreates the desktop." Perhaps the edit makes that clearer. –  jwd630 Apr 16 at 21:53

I would take a look at this guide from the CrashPlan website titled: CONFIGURING A HEADLESS CLIENT. It spells out the details of how one would go about installing CrashPlan for use in a headless situation, which is really what you want.

But I just want to disable the GUI

If you're using a desktop environment such as GNOME you can launch the configuration dialog, gnome-session-properties and configure what apps are auto started when you login.

      ss of auto

Simply uncheck or remove it all together to stop CrashPlan from launching. In the above I'm showing a similar GUI that gets launched by DropBox, but the method is the same.

share|improve this answer
    
I upvoted your answer anyway, but it's not exactly what I am looking for (I had already read that guide). I am interested to know how to disable (and optionally re-enable the GUI service) rather than how to configure CrashPlan in headless mode. This way I could xrdp to the server without having to change the app's configuration from the remote machine to connect to the headless CrashPlan running on the server. –  user1301428 Apr 11 at 8:45
    
@user1301428 - thanks. I still don't really understand your issue then. I use XRDP for both home and work and have a pretty extensive understanding of it. I'm not sure how the other A even answers your actual Q either. What he says isn't true that it recreates the desktop. When you RDP into the system and run a program and then disconnect and then come back, the app is still running, correct? So the CrashPlan GUI is still running. –  slm Apr 11 at 8:52
    
@user1301428 - if you do not want the CP GUI to run regardless of RDPing in or not, I'd look to your DE's auto starting of apps and simply disable CP there. I'll add an example to this A. –  slm Apr 11 at 9:04
    
Thank you very much, I'll give it a try :) –  user1301428 Apr 11 at 13:21
    
@user1301428 - let me know how you make out. –  slm Apr 11 at 13:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.