Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I use Ubuntu.. In 'gnome-terminal', I can type Unicode Codepoints by first typing Ctrl-Shift-u followed by the Codepoint hex value, eg. C-S-u 2468 produces ⑨

konsole, my preferred terminal, does not have this C-S-u (gnome) feature..

Is there some equivalent KDE way to do this in Konsole?

share|improve this question
    
Ran into this issue too when I set GTK_IM_MODULE=xim so that I could use ~/.Xcompose. Better question would be "How to input Unicode characters by codepoint when using XIM?". –  Arrowmaster Apr 28 '11 at 20:38
1  
This is a feature of the GTK widget set used by all GNOME applications. You will need to find a similar feature offered by QT used by KDE applications. Look up QT IMM modules. –  penguin359 Apr 28 '11 at 21:27

1 Answer 1

I did some research on this, and apparently the en vogue input system at the moment is IBus. It supports GTK+ and Qt.

Here is what I did to set it up on a Debian system:

  • Install ibus, ibus-gtk, ibus-qt4, and ibus-m17n. The latter contains the input method that supports entering Unicode characters by codepoint. There are several other packages that contain other input methods, mostly aimed at CJK.
  • In the GNOME menu, under System->Preferences->IBus Preferences, select tab "Input Method" and select Other->"unicode (m17n)".
  • It might be best at this point to restart your entire GDM session to get the IBus initialization run. Alternatively, the preferences menu will offer to start the IBus daemon, but then you will have to set the environment variables it tells you manually and start a new konsole (or whatever) window in that environment.
  • Assuming you now have a new konsole window, find the IBus icon in the system tray and choose the "unicode (m17n)" input method. If it says "No input window", you probably don't have the right window focused. (Kind of annoying when you use focus follows mouse. It's probably possible to configure this better.)
  • Now press Ctrl+u and then enter the codepoint, e.g., 2468 (hexadecimal, as before). Voilà!
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.