Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've a bought a QBox-1000, I've installed Wheezy, and some services (SSH, Samba, Transmission, etc). Now I would like to step on a next level. I want to know what is what and how to do some advanced operations eg. I connected a Logitech Quickcam E2500, something went wrong, because first I could record with it, but there wasn't sound. Then I've tried several things, and now the system doesn't load the cameras's driver (may be there is no driver at all).

Please let me know what is the theory and after that tell me how MAKE (or load or install) the specific driver. (as I see I need this driver / modul: GSPCA )

As I know the theory is:

  • connect the device
  • install / setup the driver
  • install / setup application
  • use the application

root@qbox:~# uname -a
Linux qbox 3.2.0-4-686-pae #1 SMP Debian 3.2.54-2 i686 GNU/Linux

root@qbox:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 1687:2029 Kingmax Digital Inc.
Bus 003 Device 002: ID 046d:089d Logitech, Inc. QuickCam E2500 series

root@qbox:~# dmesg | grep usbcore
[    9.865932] usbcore: registered new interface driver usbfs
[    9.866022] usbcore: registered new interface driver hub
[    9.881131] usbcore: registered new device driver usb
[   10.393143] usbcore: registered new interface driver usb-storage
[   11.587918] usbcore: registered new interface driver snd-usb-audio

I found this and this, but if I take a look in my filesystem, there are no files like that:

/lib/modules/3.2.0-4-686-pae/kernel/drivers/media/video/gspca/gl860/gspca_gl860.ko
/lib/modules/3.2.0-4-686-pae/kernel/drivers/media/video/gspca/gspca_spca500.ko

There are the folders, but they are empty. May be I should build my own driver from source, but all attempts have failed. If I want to (re)install the package:

root@qbox:~# apt-get install linux-image-3.2.0-4-686-pae
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-image-3.2.0-4-686-pae is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

or the header...

root@qbox:~# apt-get install linux-headers-3.2.0-4-686-pae
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-headers-3.2.0-4-686-pae is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

root@qbox:~# apt-get --reinstall install linux-image-3.2.0-4-686-pae
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 22.9 MB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ftp.debian.org/debian/ stable/main linux-image-3.2.0-4-686-pae i386                                                  3.2.54-2 [22.9 MB]
Fetched 22.9 MB in 7s (3,139 kB/s)
Preconfiguring packages ...
(Reading database ... 45853 files and directories currently installed.)
Preparing to replace linux-image-3.2.0-4-686-pae 3.2.54-2 (using .../linuximage-3.2.0-4-686-pae_3.2.54-2_i386.deb) ...
Unpacking replacement linux-image-3.2.0-4-686-pae ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-4-686-pae /boot/vmlinuz-3.2.0-4-686-pae
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-4-686-pae /boot/vmlinuz-3.2.0-4-686-pae
Setting up linux-image-3.2.0-4-686-pae (3.2.54-2) ...
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4-686-pae /boot/vmlinuz-3.2.0-4-686-pae
update-initramfs: Generating /boot/initrd.img-3.2.0-4-686-pae
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-4-686-pae /boot/vmlinuz-3.2.0-4-686-pae
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.0-4-686-pae /boot/vmlinuz-3.2.0-4-686-pae
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.2.0-4-686-pae
Found initrd image: /boot/initrd.img-3.2.0-4-686-pae
Found Windows Recovery Environment (loader) on /dev/sdb1
done

After reinstall...

root@qbox:~# dmesg | grep usbcore
[    9.900699] usbcore: registered new interface driver usbfs
[    9.900787] usbcore: registered new interface driver hub
[    9.915960] usbcore: registered new device driver usb
[   10.408958] usbcore: registered new interface driver usb-storage
[   11.391045] usbcore: registered new interface driver zc3xx
[   11.566040] usbcore: registered new interface driver snd-usb-audio

This one I missed: zc3xx

share|improve this question
    
Interesting, you caould try reinstalling the package and see if that makes a difference or if there is any error during installation. apt-get --reinstall install linux-image-3.2.0-4-686-pae –  Graeme Mar 30 at 22:00
    
Also if you are going to use <code> tags, you should wrap them in <pre> tags. Eg <pre><code>some code</code></pre>. Or just indent each line by 4 spaces, you can do this for multiple lines by highlighting a block and pressing Ctrl-K. –  Graeme Mar 30 at 22:06
    
I've reinstalled... –  ruky Mar 30 at 22:21
    
Have you checked to see if files are there now? This must surely be an installation issue - if the files are listed as being in the package, then they should be on the system. Since the package is now cached on you system, you can check its contents with dpkg -c /var/cache/apt/archives/linux-image-3.2.0-4-686-pae_3.2.54-2_i386.deb | grep gspca. –  Graeme Mar 30 at 22:33
    
aaaaa THX! the files are OK now... and the system loaded the driver... please make an answer (and I'll accept it) THX again! –  ruky Mar 30 at 23:08

2 Answers 2

up vote 2 down vote accepted

As @Graeme said, you can reinstall the package with

sudo apt-get --reinstall install linux-image-3.2.0-4-686-pae

This should reinstall all the files (including the ones you are missing).

Note - since @Graeme did not end up posting his comment as an answer this is the right thing to do, see this meta post.

You should also run:

sudo apt-get install firmware-realtek

to take care of the missing firmware for your NIC.

share|improve this answer
    
sorry I can't rate up (yet) :-( THX again! –  ruky Mar 30 at 23:46

The issue was that the driver was listed as being in the package, but for some reason wasn't on the system. This probably happened due to some error in the installation. Simply re-installing is the first thing to try:

sudo apt-get --reinstall install linux-image-3.2.0-4-686-pae

Note that without the --reinstall, apt-get will just note that the package is already installed and then not do anything. If the files weren't there afterwards, apt-get should at least give a reason.

Generally, you want to make sure the files are installed properly from the package, because if they aren't this will likely not be the only issue you have.

For future reference, you can use apt-file to find out which packages a particular file is in. Usually you would first you would update the database with:

sudo apt-file update

And the search with:

apt-file search gspca_gl860.ko
share|improve this answer
    
Sorry, didn't think you were going to answer the question. +1 –  PlasmaPower Mar 31 at 0:24
    
@PlasmaPower, no prob –  Graeme Mar 31 at 0:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.