Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running this as a debian wheezy inside a vm with NAT networking with a win7 host.

When I try to install pidgin using

sudo apt-get install pidgin

I get following error

Err http://security.debian.org/ wheezy/updates/main pidgin amd64.2.10.9-1~deb7u1   403  Forbidden 
Failed to fetch http://security.debian.org/pool/updates/main/p/pidgin/pidgin_2.10.9-1~deb7u1_amd64.deb
403  Forbidden E: Unable to fetch some archives, maybe run apt-get
update or try with --fix-missing?

As mentioned I tried to execute

sudo apt-get update
sudo apt-get --fix-missing update

And get

errors: Ign ftp.uk.debian.org wheezy-updates/main amd64 Packages/DiffIndex Err dl.google.com stable/main amd64 Packages 403 Forbidden
E: Some index files failed to download. They have been ignored, or old ones used instead

My sources.list includes the following lines + some internal ones:

deb http://http.debian.net/debian wheezy main
deb-src http://http.debian.net/debian wheezy main

deb http://http.debian.net/debian wheezy-updates main
deb-src http://http.debian.net/debian wheezy-updates main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main


ping or google.com results in no reply

I old tried changing my sources to use .de instead of .uk but the same issue


after trying on a new vm inside linux mint I am still having issues.

I had a look at /etc/resolve.conf and I have the following settings:

domain home
search home

however on my host I have:

search home
share|improve this question

closed as off-topic by Jeff Schaller, Jakuje, PersianGulf, Scott, Anthon May 3 at 5:42

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Jakuje, PersianGulf, Scott, Anthon
If this question can be reworded to fit the rules in the help center, please edit the question.

pidgin is in fact included in the packages security packages.debian.org/wheezy/pidgin what is the content of the file /etc/apt/sources.list, Or maybe you mean that you need to do it without apt-get and then your question is unclear. if you can't do it with apt why because the reasons might not be relevant. – Kiwy Mar 24 '14 at 9:08
@Kiwy can you see my edit – FutuToad Mar 24 '14 at 9:29
WHY can't you use sudo apt-get install pidgin – Kiwy Mar 24 '14 at 9:30
@Kiwy please see edit no2 – FutuToad Mar 24 '14 at 9:54
Are you using a proxy or firewall? – goldilocks Mar 24 '14 at 12:26

Since you're getting a 403 I'm going to assume that you're have internet access working. Try downloading the .deb files directly via the command line.

$ wget http://security.debian.org/pool/updates/main/p/pidgin/pidgin_2.10.9-1~deb7u1_amd64.deb

Things that could be an issue here:

  1. DNS
  2. APT installation/config is hosed
  3. The URL is down

As I said since you're able to surf the internet from within the VM using a browser and the fact that you're getting a HTTP status code of 403 (Forbidden) leads me to think it's something else and not the network being down.

share|improve this answer
I'm not really wanting to do a manual download. I only care now that I can access ftp.uk.debian.org .. etc etc. can you check my question update – FutuToad Mar 24 '14 at 19:28
@FutuToad - Yeah I wasn't suggesting a manual download, only to confirm that the above wget command worked for you since that's what apt-get is doing itself. – slm Mar 24 '14 at 20:35
its all a bit dispairing, im gonna just forget the vm and work direct with the linux os over hardware – FutuToad Mar 24 '14 at 21:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.