Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have just installed CentOS 6.5 minimal. The reason I installed the minimal version is that the full version had ISOs of over 3GB each and my CD-RWs can only told about 750 MB.

I would like a graphical desktop. I tried

sudo yum update
sudo yum groupinstall basic-desktop desktop-platform x11 fonts

and they both ran without any errors. However, when I tried to run the desktop using

sudo gdm

and it just hung in the command line. When I tried

gdm

I got

** (gdm-binary:2164): WARNING **: Failed to acquire org.gnome.DisplayManager: Connection "1.37" is not allowed to own the service "org.gnome.DisplayManager" due to security policies in the configuration file

 ** (gdm-binary:2164): WARNING **: Could not acquire name; bailing out
share|improve this question

2 Answers 2

Try doing the following instead.

Install Desktop Packages
$ sudo yum -y groupinstall "Desktop" "Desktop Platform" \
        "X Window System" "Fonts"
optional GUI packages
$ sudo yum -y groupinstall "Graphical Administration Tools"
$ sudo yum -y groupinstall "Internet Browser"
$ sudo yum -y groupinstall "General Purpose Desktop"
$ sudo yum -y groupinstall "Office Suite and Productivity"
$ sudo yum -y groupinstall "Graphics Creation Tools"

NOTE: To make the GUI permanent between reboots you'll need to change your runlevel to 5. Open this file: `/etc/inittab using a text editor and change the following line:

id:3:initdefault:

To:

id:5:initdefault:

References

share|improve this answer
    
I tried that and got "No packages in any requested group available to install or update". "sudo gdm" still just hangs. Thanks, –  OtagoHarbour Mar 24 at 12:06
    
@OtagoHarbour - you might want to confirm the list of groups that I've provided matches existing group names. You can use yum grouplist. –  slm Mar 24 at 12:25
    
"Desktop" and "Desktop Platform" are both on the list when I do that. Thanks, –  OtagoHarbour Mar 25 at 0:58

On my minimal CentOS 7 I did: sudo yum -y groupinstall "GNOME Desktop" and then startx and everything work fine.

you can do yum groups list to check what group are available.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.