Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to set up a Redmine on my server, and I am following THIS setup guide. I have used this guide before on my VPS and it worked perfectly however on this server I get following error when I try to generate public key.

aristotle:~# sudo su - redmine
No directory, logging in with HOME=/
redmine@aristotle:/$ ssh-keygen -t rsa -N '' -f ~/.ssh/gitolite_admin_id_rsa
Generating public/private rsa key pair.
open //.ssh/gitolite_admin_id_rsa failed: No such file or directory.
Saving the key failed: //.ssh/gitolite_admin_id_rsa.
redmine@aristotle:/$
share|improve this question

1 Answer 1

up vote 0 down vote accepted

Ok solved ... I just had to do

sudo mkdir .ssh in that directory

share|improve this answer
    
Why exactly you needed to do that? –  Braiam Mar 20 at 23:40
    
to generate key for admin user –  Maciej Cygan Mar 20 at 23:42
    
Could you give us the pointers that lead you to your answer, is what I wanted to ask. –  Braiam Mar 20 at 23:43
    
It said "no such file or directory" i was confused at first.. as i have simply forgot that .ssh is a file, and since that error was thrown this file did not exist so i just create it –  Maciej Cygan Mar 20 at 23:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.