Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed FreeBSD on an Intel SS4200-EHW which has four hard disks and a flash DOM (Disk On Module) disk through an IDE interface. I want to install FreeBSD on the Flash DOM. In order to get the FreeBSD installer to find the Flash DOM, I've used the hints from here - by adding the following "hints" before "booting" the installer:

set hint.ata.0.at="isa"
set hint.ata.0.port="0x1F0"
set hint.ata.0.irq="14"

The installer finds the correct disk and installs without any issues. I also made sure the disk/partition is set with the bootable flag.

When I boot from the Flash DOM, I get the following error message: "No ufs" and end up with a prompt starting with "boot:".

Not sure why this is. Might be that I wasn't able to persist the hint information to any configurations files during the install. Anyone knowing how I can ensure that this get persisted. Any other way to get further to diagnose this issue?

Update Based on feedback I've included the boot image I am stranded at:Boot screen image

The "tab" key doesn't work.

Also I booted PC-BSD to try to edit the files from there and I'm able to mount all other partitions except the boot partition. The image below shows error message when trying to access the MBR partition: PC-BSD file browser which shows mounted partitions and the failed partition

share|improve this question

I believe you are stuck at the boot2 stage which normally loads loader. loader is what is responsible for loading in hints, the kernel, and additional modules needed. The hints won't help boot2 find loader, they are for telling the the FreeBSD kernel how to find the hardware since FreeBSD has it's own device drivers and doesn't use the BIOS. boot2 and loader both rely on BIOS to talk to the hardware. The fact that you got to boot2 should indicate the BIOS is able to access your DOM, but boot2 doesn't know which device it is. You should have some limited command functionality and/or tab completion. I don't have a FreeBSD box in front of me to test with but try typing either ?, h, or help. Also, try tab completion by typing (<TAB> or (ad<TAB> or (da<TAB> and see if it lists possible devices. I can also pull up a box later and test myself.

share|improve this answer
I've tried to write "help", "--help" and "?", but without any luck. Will try later to use tab completion to see if that helps. My guess here is that I need to modify the device.hints file, but I couldn't find a possibility to do this during the installer. – tronda Apr 27 '11 at 7:20
@tronda I will reiterate that I don't think it's a hints issue at this point. You will reach the full screen menu on FreeBSD where one can select safe mode or other options before the device.hints file has any effect. I think it's simply that boot1 is not finding the right device/partition. Can you post a screenshot or pic of where it's stuck or any additional output? I will try to boot up a FreeBSD to test myself. – penguin359 Apr 27 '11 at 22:07
I've added a screenshot and a little more information. – tronda May 1 '11 at 20:00
@tronda yep, it's stuck at boot2 whose job is to load /boot/loader. It's using Atapi Disk 0 AKA C: AKA hda AKA primary master. Try running 4:ad(0,a)/boot/loader at the prompt. The first number is the disk number. You can try varying that from 0-7. The second number is the MS-DOS partition known as slice number in FreeBSD speak. Slice 0 means first primary partition. The a is the FreeBSD partition which should always be a. – penguin359 May 1 '11 at 20:24

I've also installed FreeBSD 8.2 on my Intel SS4200. I installed 8.1 and upgraded to 8.2 via CLI.

Have a look at these 2 pages to get your SS4200 up and running with FreeBSD 8.1:

http://ss4200.pbworks.com/w/page/5122750/FreeNAS-0_70 and http://ss4200.pbworks.com/w/page/19270391/FreeBSD.

More specifically, you need to edit /boot/loader.conf (for serial console) and /boot/device.hints.

share|improve this answer
How do you edit them during the install process? Tried to boot up a Live CD version of PC-BSD, but could mount the disk to actually edit those files. – tronda Apr 27 '11 at 11:14
If I'm not mistaken (I installed a while ago), I had to: install FreeBSD to the DOM, exit the installer (or reboot with the CD, I don't remember), mount the DOM, edit those 2 files and reboot. – Tnkflx May 2 '11 at 7:17
up vote 0 down vote accepted

By choosing to install FreeBSD with a boot manager instead of making the Flash DOM / (root) partition a MBR partition, I was able to boot the SS4200 box.

To get FreeBSD up and running I had to go into the boot loader prompt to add the hints before booting FreeBSD and then I just modified the device.hints file. A reboot after this change made the SS4200 boot without any issues.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.