Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a very interesting issue. We have Redhat 4 Linux and it is has 4 ethernet interfaces:

eth0
eth1
eth2
eth3

Now, only eth0 is connected to LAN and everything is working fine. We have special software which needs eth2 and won't work without the eth2 interface. I therefore want to convert eth0 to eth2.

I don't have a 70-persistent-networking.rules file in udev. It looks like we have a very old version of udev running and it doesn't use that file.

/etc/modprobe.conf:

alias eth0 bnx2
alias eth1 bnx2
alias eth2 bnx2
alias eth3 bnx2

I have tried to swap MAC address in ifcfg-eth files but still not working.

Note: we can't swap the cables because this server is a blade server inside a chassis, and the server is located in a remote datacenter.

share|improve this question

As a workaround you may be able to create two devices reserving the names eth0 and eth1 before loading the actual network driver which then should use eth2. There's a kernel module named dummy with which you should be able to accomplish this:

modprobe dummy numdummies=2
ip l set dev dummy0 name eth0
ip l set dev dummy1 name eth1
share|improve this answer

I don't have 70-persistent-networking.rules file in udev, look like we have very old version of udev running and it doesn't use that file.

I'm no expert on the evolution of udev, but if there's somewhere you're not finding that file (/etc/udev/rules.d), then you can create it. udev just processes files in that directory in lexicographical order -- that's why they use names beginning with numbers. However, it should still read and apply every .rules file there. Might as well save yours for last, so put whatever you want into /etc/udev/rules.d/99-my.rules.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.