Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

On an otherwise untouched installation of Fedora 20 Security Lab, I'm trying to enable NX access so I don't have to use Windows and the vSphere console. I have to use SSH to reach the host, no other ports are open. I'm able to connect to other machines running CentOS and Scientific Linux under the same network conditions.

I start by setting sshd to start on boot:

systemctl enable sshd.service

Then I grab freenx:

yum install freenx-server

Then the dependency for nxagent:

yum install nxagent

I then configure the nxserver via /etc/nxserver/node.conf:

SSHD_PORT=22
ENABLE_PASSDB_AUTHENTICATION="1"
ENABLE_SSH_AUTHENTICATION="1"
DISPLAY_BASE=1000
ENABLE_PERSISTENT_SESSION="all"
ENABLE_CLIPBOARD="both"
ENABLE_PULLDOWN_MENU="1"
COMMAND_MD5SUM="md5sum"

Then from the /usr/libexec/nx directory:

./nxsetup --install --setup-nomachine-key

This returns the following:

Setting up /etc/nxserver ...done
Generating public/private dsa key pair.
Your identification has been saved in /etc/nxserver/users.id_dsa.
Your public key has been saved in /etc/nxserver/users.id_dsa.pub.
The key fingerprint is:
69:ad:50:52:59:d3:9d:93:77:d7:94:68:dc:eb:8b:92 root@localhost.localdomain
The key's randomart image is:
+--[ DSA 1024]----+
|        .oo...o++|
|       ..  ..+=o=|
|      . .   .  o+|
|       o o     . |
|      . S .   .  |
|       o .     . |
|        .   . . .|
|           E . . |
|            .    |
+-----------------+
Setting up /var/lib/nxserver/db ...done
Setting up /var/log/nx/nxserver.log ...done
Adding user "nx" to group "utmp" ...done
Setting up known_hosts and authorized_keys ...done
Setting up permissions ...done

----> Testing your nxserver configuration ...
Warning: Invalid value "APPLICATION_LIBRARY_PRELOAD=/usr/lib64/nx/libX11.so.6:/usr/lib64/nx/libXext.so.6:/usr/lib64/nx/libXcomp.so.3:/usr/lib64/nx/libXcompext.so.3:/usr/lib64/nx/libXrender.so.1". /usr/lib64/nx/libX11.so.6 could not be found. Users will not be able to run a single application in non-rootless mode.
Warning: Invalid value "COMMAND_START_KDE=startkde"
         Users will not be able to request a KDE session.
Warning: Invalid value "COMMAND_START_GNOME=gnome-session"
         Users will not be able to request a Gnome session.
Warning: Invalid value "COMMAND_START_CDE=cdwm"
         Users will not be able to request a CDE session.
Warning: Invalid value "COMMAND_XTERM=xterm"
         Users will not be able to request an xterm session.
Warning: Invalid value "COMMAND_SMBMOUNT=smbmount". You'll not be able to use SAMBA. 
Warning: Invalid value "COMMAND_SMBUMOUNT=smbumount". You'll not be able to use SAMBA.
Warning: Invalid cupsd version of "/usr/sbin/cupsd". Need version 1.2.
         Users will not be able to enable printing. Ignore if you use cups > 1.2
Error: Could not find 1.5.0 or 2.[01].0 or 3.[012345].0 version string in nxagent. NX 1.5.0 or 2.[01].0 or 3.[012345].0 backend is needed for this version of FreeNX.

  Warnings occured during config check.
  To enable these features please correct the configuration file.

<---- done

----> Testing your nxserver connection ...
The authenticity of host '127.0.0.1 (127.0.0.1)' can't be established.
RSA key fingerprint is 1b:2d:0e:72:56:66:1a:f3:b5:97:66:93:c7:c4:e8:93.
Are you sure you want to continue connecting (yes/no)?
Warning: Permanently added '127.0.0.1' (RSA) to the list of known hosts.
HELLO NXSERVER - Version 3.2.0-74-SVN OS (GPL, using backend: not detected)
NX> 105 quit
Quit
NX> 999 Bye
<--- done

Ok, nxserver is ready.

PAM authentication enabled:
  All users will be able to login with their normal passwords.

  PAM authentication will be done through SSH.
  Please ensure that SSHD on localhost accepts password authentication.

  You can change this behaviour in the /etc/nxserver/node.conf file.
Have Fun!

I then grab the key from /etc/nxserver/client.id_dsa.key and add a new connection in NoMachine for Mac OS X. I set it as an SSH connection, under Advanced I select "Use the NoMachine login, add my key as the alternate server key, and attempt to connect. Every single time, I get:

"The NoMachine service is not available or the access was disabled on host 10.30.5.22"

I've been Googling for days, and nothing I try seems to work. Can anybody see if I'm missing something here? I have almost no experience with NX, I'm really just poking away here, so pardon me if this looks like a noob question.

share|improve this question
    
Any chance selinux is blocking you? –  slm Mar 15 at 2:16
    
You can temp. disable it to see if it resolves your issue, setenforce 0. –  slm Mar 15 at 2:21
    
@slm - Thanks for the suggestion. It didn't solve my issue, though, which in retrospect makes sense, since CentOS also ships with SELinux enabled, yet didn't manifest this issue. Perhaps I'm oversimplifying. –  Dan Robson Mar 17 at 14:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.